summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-05-04 13:02:41 +0200
committerAlexander F. Rødseth2021-05-04 13:02:41 +0200
commit623c067a0a20ec37d43822bcfbca9a4a96050057 (patch)
tree846166b132fecb07828b40a614e0238b4f7f9d3d
parent53dad7c5ecd6ff987f0f0a1d31e33f4edb9770f9 (diff)
downloadaur-623c067a0a20ec37d43822bcfbca9a4a96050057.tar.gz
New release
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46557313307b..3b912b9eecf1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = brittany
pkgdesc = Haskell source code formatter
- pkgver = 0.12.1.1.x2
+ pkgver = 0.13.1.1
pkgrel = 1
url = https://github.com/lspitzner/brittany
arch = x86_64
license = AGPL3
+ makedepends = git
makedepends = stack
- source = https://github.com/lspitzner/brittany/archive/0.12.1.1.x2.tar.gz
- sha256sums = 97fc02baba76a42d19847f5a695af7fa1c2699e6cfbf91c2604998d8501c0d75
+ source = git+https://github.com/lspitzner/brittany#commit=4d064db674203626fe5011d10874fcbc335ec9b1
+ b2sums = SKIP
pkgname = brittany
diff --git a/PKGBUILD b/PKGBUILD
index c539fde235fc..6e6cbac55699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,22 @@
# Contributor: Damien Flament <damien.flament at gmx dot com>
pkgname=brittany
-pkgver=0.12.1.1.x2
+pkgver=0.13.1.1
pkgrel=1
pkgdesc='Haskell source code formatter'
arch=(x86_64)
url='https://github.com/lspitzner/brittany'
license=(AGPL3)
-makedepends=(stack)
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('97fc02baba76a42d19847f5a695af7fa1c2699e6cfbf91c2604998d8501c0d75')
+makedepends=(git stack)
+source=("git+$url#commit=4d064db674203626fe5011d10874fcbc335ec9b1") # tag: 0.13.1.1
+b2sums=('SKIP')
build() {
- cd $pkgname-$pkgver
+ cd $pkgname
stack build
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
stack install --local-bin-path "$pkgdir/usr/bin"
}
-
-# vim: ts=2 sw=2 et: