summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2017-11-14 09:03:29 +0000
committerColin Arnott2017-11-14 09:03:29 +0000
commit4f4ac25d05a213b5cf680924c020c761639af82b (patch)
tree5b08295be1cc7f8738a863411d85009981fa9e33
downloadaur-4f4ac25d05a213b5cf680924c020c761639af82b.tar.gz
init: v3.r24.gf1e0b2d
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0df905329d35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Nov 14 08:59:55 UTC 2017
+pkgbase = brlaser-git
+ pkgdesc = CUPS driver for the Brother DCP-7065DN
+ pkgver = v3.r24.gf1e0b2d
+ pkgrel = 1
+ url = https://github.com/pdewacht/brlaser
+ arch = x86_64
+ license = GPL2
+ depends = cups
+ source = brlaser-git::git+https://github.com/pdewacht/brlaser
+ sha512sums = SKIP
+
+pkgname = brlaser-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c5a56901402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Colin Arnott <colin@urandom.co.uk>
+pkgname="brlaser-git"
+pkgver=v3.r24.gf1e0b2d
+pkgrel=1
+pkgdesc="CUPS driver for the Brother DCP-7065DN"
+arch=('x86_64')
+url="https://github.com/pdewacht/brlaser"
+license=('GPL2')
+
+depends=('cups')
+source=("$pkgname::git+$url")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}