summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2016-10-12 22:10:46 +0200
committerRaimar Bühmann2016-10-12 22:11:21 +0200
commit757d4772cd6e315e7cc2ec328da8187f07355ba4 (patch)
treec2a89936c6be971fb2fbc575b421cad00fa113bd
parent9d6f10b1b7745fbf5d140ac749e2253caf70daa8 (diff)
downloadaur-757d4772cd6e315e7cc2ec328da8187f07355ba4.tar.gz
add linux48.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--linux48.patch52
3 files changed, 62 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fde2f093272a..fd50cfee1291 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = broadcom-wl
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver
pkgver = 6.30.223.271
- pkgrel = 3
- url = http://www.broadcom.com/support/802.11
+ pkgrel = 4
+ url = https://www.broadcom.com/support/802.11
install = install
arch = i686
arch = x86_64
@@ -13,10 +13,12 @@ pkgbase = broadcom-wl
source = license.patch
source = wl_linux.c.patch
source = linux47.patch
+ source = linux48.patch
sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
sha256sums = 2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac
sha256sums = 583335a6edb2ed1094977c401643d3e60471c6bc5c3ea81f45910a9cccb06032
sha256sums = 30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e
+ sha256sums = 833af3b209d6a101d9094db16480bda2ad9a85797059b0ae0b13235ad3818e9c
source_i686 = http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-6_30_223_271.tar.gz
sha256sums_i686 = 4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd
source_x86_64 = http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7047a6eab483..37a94c6c427e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
pkgname=broadcom-wl
pkgver=6.30.223.271
-pkgrel=3
+pkgrel=4
pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver'
-url='http://www.broadcom.com/support/802.11'
+url='https://www.broadcom.com/support/802.11'
arch=('i686' 'x86_64')
license=('custom')
@@ -20,13 +20,15 @@ source=('modprobe.d'
'license.patch'
'wl_linux.c.patch'
'linux47.patch'
+ 'linux48.patch'
)
source_i686=("http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
source_x86_64=("http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz")
sha256sums=('b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32'
'2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac'
'583335a6edb2ed1094977c401643d3e60471c6bc5c3ea81f45910a9cccb06032'
- '30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e')
+ '30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e'
+ '833af3b209d6a101d9094db16480bda2ad9a85797059b0ae0b13235ad3818e9c')
sha256sums_i686=('4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd')
sha256sums_x86_64=('5f79774d5beec8f7636b59c0fb07a03108eef1e3fd3245638b20858c714144be')
@@ -39,6 +41,7 @@ prepare() {
patch -p1 -i license.patch
patch -p1 -i wl_linux.c.patch
patch -p1 -i linux47.patch
+ patch -p1 -i linux48.patch
sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" \
-i src/wl/sys/wl_linux.c
diff --git a/linux48.patch b/linux48.patch
new file mode 100644
index 000000000000..0f3e81906226
--- /dev/null
+++ b/linux48.patch
@@ -0,0 +1,52 @@
+Reference: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839629
+
+--- a/src/wl/sys/wl_cfg80211_hybrid.c 2016-10-03 10:53:55.588036464 +0200
++++ b/src/wl/sys/wl_cfg80211_hybrid.c 2016-10-03 10:54:11.911695944 +0200
+@@ -2386,8 +2386,15 @@
+ s32 err = 0;
+
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = true
++ };
+ WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
+- cfg80211_scan_done(wl->scan_request, true);
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
++ cfg80211_scan_done(wl->scan_request, true);
++#endif
+ wl->scan_request = NULL;
+ }
+
+@@ -2488,7 +2495,14 @@
+
+ scan_done_out:
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = false
++ };
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
+ cfg80211_scan_done(wl->scan_request, false);
++#endif
+ wl->scan_request = NULL;
+ }
+ rtnl_unlock();
+@@ -2913,7 +2927,14 @@
+ s32 err = 0;
+
+ if (wl->scan_request) {
+- cfg80211_scan_done(wl->scan_request, true);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = true
++ };
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
++ cfg80211_scan_done(wl->scan_request, true);
++#endif
+ wl->scan_request = NULL;
+ }
+