summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin K2015-05-23 16:47:01 +0200
committerArmin K2015-05-23 16:47:01 +0200
commite2d05106d9792740d300ae19b1fb944308d3d8ec (patch)
treef01119a7a2c839e62b9dbe4915ce990216c62fa7
parentca527740c70e692c084a2df8e932723b64a767fa (diff)
downloadaur-e2d05106d9792740d300ae19b1fb944308d3d8ec.tar.gz
Sync from AUR3.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
-rw-r--r--linux-recent.patch52
3 files changed, 62 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 554fc8b07859..bafbc129f53e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 4.2.0
-# Tue Dec 30 17:03:18 UTC 2014
+# Generated by makepkg 4.2.1
+# Mon Apr 13 11:27:02 UTC 2015
pkgbase = broadcom-wl
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver
pkgver = 6.30.223.248
- pkgrel = 4
+ pkgrel = 6
url = http://www.broadcom.com/support/802.11/linux_sta.php
install = install
arch = i686
@@ -19,7 +19,7 @@ pkgbase = broadcom-wl
sha256sums = 3d994cc6c05198f4b6f07a213ac1e9e45a45159899e6c4a7feca5e6c395c3022
sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
sha256sums = 2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac
- sha256sums = ebbcac3a37787c86fa8515046d81d1d0bb2669215703d6fa2800233029bf3d63
+ sha256sums = 922a5b183643db256d03b147f051fbf2032be8104412a661296efe4f781f2e59
sha256sums = b07ce80f2e079cce08c8ec006dda091f6f73f158c8a62df5bac2fbabb6989849
pkgname = broadcom-wl
diff --git a/PKGBUILD b/PKGBUILD
index d1fa6deda9f8..ebdb4477d1c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=broadcom-wl
pkgver=6.30.223.248
-pkgrel=4
+pkgrel=6
pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver'
url='http://www.broadcom.com/support/802.11/linux_sta.php'
arch=('i686' 'x86_64')
@@ -20,7 +20,7 @@ source=("http://www.broadcom.com/docs/linux_sta/hybrid-v35${_arch}-nodebug-pcoem
sha256sums=('b196543a429c22b2b8d75d0c1d9e6e7ff212c3d3e1f42cc6fd9e4858f01da1ad'
'b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32'
'2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac'
- 'ebbcac3a37787c86fa8515046d81d1d0bb2669215703d6fa2800233029bf3d63'
+ '922a5b183643db256d03b147f051fbf2032be8104412a661296efe4f781f2e59'
'b07ce80f2e079cce08c8ec006dda091f6f73f158c8a62df5bac2fbabb6989849')
[[ $CARCH = x86_64 ]] && sha256sums[0]='3d994cc6c05198f4b6f07a213ac1e9e45a45159899e6c4a7feca5e6c395c3022'
@@ -31,28 +31,28 @@ _extramodules="extramodules-${_kernmajor}-ARCH"
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
prepare() {
- cd "${srcdir}"
+ cd "${srcdir}"
- patch -p1 -i linux-recent.patch
- patch -p1 -i license.patch
- patch -p1 -i gcc.patch
+ patch -p1 -i linux-recent.patch
+ patch -p1 -i license.patch
+ patch -p1 -i gcc.patch
- sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" \
- -i src/wl/sys/wl_linux.c
+ sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" \
+ -i src/wl/sys/wl_linux.c
}
build() {
- cd "${srcdir}"
+ cd "${srcdir}"
- make -C /usr/lib/modules/${_kernver}/build M=`pwd`
+ make -C /usr/lib/modules/${_kernver}/build M=`pwd`
}
package() {
- cd "${srcdir}"
+ cd "${srcdir}"
- install -Dm644 wl.ko "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
- gzip "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
+ install -Dm644 wl.ko "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
+ gzip "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
- install -Dm644 lib/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 modprobe.d "${pkgdir}/usr/lib/modprobe.d/broadcom-wl.conf"
+ install -Dm644 lib/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 modprobe.d "${pkgdir}/usr/lib/modprobe.d/broadcom-wl.conf"
}
diff --git a/linux-recent.patch b/linux-recent.patch
index 05e4e1303105..81d27204b4e0 100644
--- a/linux-recent.patch
+++ b/linux-recent.patch
@@ -1,5 +1,5 @@
---- a/src/wl/sys/wl_cfg80211_hybrid.c 2014-06-26 10:42:08.000000000 +0000
-+++ b/src/wl/sys/wl_cfg80211_hybrid.c 2014-12-30 17:02:13.602127370 +0000
+--- a/src/wl/sys/wl_cfg80211_hybrid.c 2014-06-26 12:42:08.000000000 +0200
++++ b/src/wl/sys/wl_cfg80211_hybrid.c 2015-04-13 13:20:08.140013177 +0200
@@ -63,8 +63,13 @@
static s32 wl_cfg80211_join_ibss(struct wiphy *wiphy, struct net_device *dev,
struct cfg80211_ibss_params *params);
@@ -39,7 +39,31 @@
{
struct wl_cfg80211_priv *wl = wiphy_to_wl(wiphy);
scb_val_t scb_val;
-@@ -2010,9 +2021,15 @@
+@@ -1441,7 +1452,11 @@
+ WL_DBG(("Could not get rate (%d)\n", err));
+ } else {
+ rate = dtoh32(rate);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 0, 0)
+ sinfo->filled |= STATION_INFO_TX_BITRATE;
++#else
++ sinfo->filled |= BIT(NL80211_STA_INFO_TX_BITRATE);
++#endif
+ sinfo->txrate.legacy = rate * 5;
+ WL_DBG(("Rate %d Mbps\n", (rate / 2)));
+ }
+@@ -1454,7 +1469,11 @@
+ return err;
+ }
+ rssi = dtoh32(scb_val.val);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 0, 0)
+ sinfo->filled |= STATION_INFO_SIGNAL;
++#else
++ sinfo->filled |= BIT(NL80211_STA_INFO_SIGNAL);
++#endif
+ sinfo->signal = rssi;
+ WL_DBG(("RSSI %d dBm\n", rssi));
+ }
+@@ -2010,9 +2029,15 @@
notify_ie = (u8 *)bi + le16_to_cpu(bi->ie_offset);
notify_ielen = le32_to_cpu(bi->ie_length);
@@ -55,7 +79,7 @@
if (unlikely(!cbss))
return -ENOMEM;
-@@ -2071,7 +2088,26 @@
+@@ -2071,7 +2096,26 @@
wl_get_assoc_ies(wl);
memcpy(&wl->bssid, &e->addr, ETHER_ADDR_LEN);
wl_update_bss_info(wl);
@@ -82,7 +106,7 @@
set_bit(WL_STATUS_CONNECTED, &wl->status);
wl->profile->active = true;
}
-@@ -2629,7 +2665,15 @@
+@@ -2629,7 +2673,15 @@
void wl_cfg80211_detach(struct net_device *ndev)
{
@@ -99,8 +123,8 @@
wl_deinit_cfg80211_priv(wl);
wl_free_wdev(wl);
---- a/src/wl/sys/wl_dbg.h 2014-06-26 10:42:08.000000000 +0000
-+++ b/src/wl/sys/wl_dbg.h 2014-12-30 17:02:03.840957429 +0000
+--- a/src/wl/sys/wl_dbg.h 2014-06-26 12:42:08.000000000 +0200
++++ b/src/wl/sys/wl_dbg.h 2015-04-13 13:19:52.443345832 +0200
@@ -55,10 +55,12 @@
#define WL_NONE(args)
@@ -115,8 +139,8 @@
#endif
#define WL_TRACE(args)
#define WL_APSTA_UPDN(args)
---- a/src/wl/sys/wl_linux.c 2014-06-26 10:42:08.000000000 +0000
-+++ b/src/wl/sys/wl_linux.c 2014-12-30 17:02:03.841957446 +0000
+--- a/src/wl/sys/wl_linux.c 2014-06-26 12:42:08.000000000 +0200
++++ b/src/wl/sys/wl_linux.c 2015-04-13 13:19:52.443345832 +0200
@@ -878,7 +878,7 @@
static SIMPLE_DEV_PM_OPS(wl_pm_ops, wl_suspend, wl_resume);
#endif
@@ -160,6 +184,16 @@
WL_UNLOCK(wl);
done1:
+@@ -2157,8 +2159,8 @@
+ wlif = WL_DEV_IF(dev);
+ wl = WL_INFO(dev);
+
++ skb->prev = NULL;
+ if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
+- skb->prev = NULL;
+
+ TXQ_LOCK(wl);
+
@@ -2455,8 +2457,10 @@
p80211msg_t *phdr;