summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2018-02-18 12:16:39 -0500
committergraysky2018-02-18 12:16:39 -0500
commit7b1ebe197ee7d8c3ac5397ac3c3938b6d69c7569 (patch)
tree865c167769b37faa8f4fad26484a587ab2a02ce0
parent4f9474ca5d01a8a9a5d71139c4566c7a472fff8b (diff)
downloadaur-7b1ebe197ee7d8c3ac5397ac3c3938b6d69c7569.tar.gz
Update to 6.30.223.271-69
-rw-r--r--.SRCINFO14
-rw-r--r--008-linux415.patch46
-rw-r--r--PKGBUILD18
3 files changed, 65 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6287afd75fd8..25659b3be216 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Feb 8 01:42:49 UTC 2018
+# Sun Feb 18 17:16:38 UTC 2018
pkgbase = broadcom-wl-ck
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.
pkgver = 6.30.223.271
- pkgrel = 68
+ pkgrel = 69
url = https://www.broadcom.com/support/802.11
arch = x86_64
license = custom
- makedepends = linux-ck-headers>=4.14
- makedepends = linux-ck-headers<4.15
- depends = linux-ck>=4.14
- depends = linux-ck<4.15
+ makedepends = linux-ck-headers>=4.15
+ makedepends = linux-ck-headers<4.16
+ depends = linux-ck>=4.15
+ depends = linux-ck<4.16
source = http://www.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz
source = 001-null-pointer-fix.patch
source = 002-rdtscl.patch
@@ -19,6 +19,7 @@ pkgbase = broadcom-wl-ck
source = 005-debian-fix-kernel-warnings.patch
source = 006-linux411.patch
source = 007-linux412.patch
+ source = 008-linux415.patch
source = modprobe.d
sha256sums = 5f79774d5beec8f7636b59c0fb07a03108eef1e3fd3245638b20858c714144be
sha256sums = 32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f
@@ -28,6 +29,7 @@ pkgbase = broadcom-wl-ck
sha256sums = 2306a59f9e7413f35a0669346dcd05ef86fa37c23b566dceb0c6dbee67e4d299
sha256sums = 5bc12cb57712e6a944dff1c90de50135c2508085d8497ab99284ccccdb35c32b
sha256sums = a3d13e8abb96ad440dbfae29acae82d31d1ced2ea62052f1efb2c3c4add347ce
+ sha256sums = 08c24157cf3b93b60e67e600d1d90223447361990df09acfb00281d79813d167
sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
pkgname = broadcom-wl-ck
diff --git a/008-linux415.patch b/008-linux415.patch
new file mode 100644
index 000000000000..1bced2f68ab1
--- /dev/null
+++ b/008-linux415.patch
@@ -0,0 +1,46 @@
+--- a/src/wl/sys/wl_linux.c 2017-07-17 00:11:24.000000000 +0100
++++ b/src/wl/sys/wl_linux.c 2018-01-27 09:49:47.057799596 +0000
+@@ -93,7 +93,11 @@
+
+ #include <wlc_wowl.h>
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++static void wl_timer(struct timer_list *tl);
++#else
+ static void wl_timer(ulong data);
++#endif
+ static void _wl_timer(wl_timer_t *t);
+ static struct net_device *wl_alloc_linux_if(wl_if_t *wlif);
+
+@@ -2297,10 +2301,17 @@
+ atomic_dec(&t->wl->callbacks);
+ }
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++static void
++wl_timer(struct timer_list *tl)
++{
++ wl_timer_t *t = (wl_timer_t *)tl;
++#else
+ static void
+ wl_timer(ulong data)
+ {
+ wl_timer_t *t = (wl_timer_t *)data;
++#endif
+
+ if (!WL_ALL_PASSIVE_ENAB(t->wl))
+ _wl_timer(t);
+@@ -2352,9 +2363,13 @@
+
+ bzero(t, sizeof(wl_timer_t));
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 15, 0)
++ timer_setup(&t->timer, wl_timer, 0);
++#else
+ init_timer(&t->timer);
+ t->timer.data = (ulong) t;
+ t->timer.function = wl_timer;
++#endif
+ t->wl = wl;
+ t->fn = fn;
+ t->arg = arg;
diff --git a/PKGBUILD b/PKGBUILD
index 9dd70c3ffc18..9550889f981b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,16 @@
pkgname=broadcom-wl-ck
pkgver=6.30.223.271
-pkgrel=68
+pkgrel=69
_pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.'
-_extramodules="extramodules-4.14-ck"
+_extramodules="extramodules-4.15-ck"
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
pkgdesc="${_pkgdesc}"
arch=('x86_64')
url='https://www.broadcom.com/support/802.11'
license=('custom')
-depends=('linux-ck>=4.14' 'linux-ck<4.15')
-makedepends=('linux-ck-headers>=4.14' 'linux-ck-headers<4.15')
+depends=('linux-ck>=4.15' 'linux-ck<4.16')
+makedepends=('linux-ck-headers>=4.15' 'linux-ck-headers<4.16')
#replaces=()
#groups=('ck-generic')
source=(
@@ -27,6 +27,7 @@ source=(
'005-debian-fix-kernel-warnings.patch'
'006-linux411.patch'
'007-linux412.patch'
+ '008-linux415.patch'
'modprobe.d'
)
sha256sums=('5f79774d5beec8f7636b59c0fb07a03108eef1e3fd3245638b20858c714144be'
@@ -37,6 +38,7 @@ sha256sums=('5f79774d5beec8f7636b59c0fb07a03108eef1e3fd3245638b20858c714144be'
'2306a59f9e7413f35a0669346dcd05ef86fa37c23b566dceb0c6dbee67e4d299'
'5bc12cb57712e6a944dff1c90de50135c2508085d8497ab99284ccccdb35c32b'
'a3d13e8abb96ad440dbfae29acae82d31d1ced2ea62052f1efb2c3c4add347ce'
+ '08c24157cf3b93b60e67e600d1d90223447361990df09acfb00281d79813d167'
'b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32')
prepare() {
@@ -47,19 +49,21 @@ prepare() {
patch -Np1 -i "$srcdir/005-debian-fix-kernel-warnings.patch"
patch -Np1 -i "$srcdir/006-linux411.patch"
patch -Np1 -i "$srcdir/007-linux412.patch"
+ patch -Np1 -i "$srcdir/008-linux415.patch"
+
+ sed -i -e '/BRCM_WLAN_IFNAME/s/eth/wlan/' src/wl/sys/wl_linux.c
}
build() {
- sed -i -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
- #sed -i -e "/EXTRA_LDFLAGS/s|\$(src)/lib|/usr/lib/${pkgname}|" Makefile
make -C /usr/lib/modules/"${_kernver}"/build M=`pwd`
}
package() {
install -Dm644 wl.ko "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
-
# makepkg does not do this automatically for this pkg so do it here
gzip "${pkgdir}/usr/lib/modules/${_extramodules}/wl.ko"
install -Dm644 lib/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 modprobe.d "${pkgdir}/usr/lib/modprobe.d/broadcom-wl_ck.conf"
}
+
+# vim: ts=2 sw=2 et: