summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2016-06-25 11:28:24 -0400
committergraysky2016-06-25 11:28:24 -0400
commitb11f4e3ea637841359c070f72bc1ad077b7fb80e (patch)
tree0621f59ab2d738628b66d9866776364b4ad99747
parente18aced0d5dc58b6796f823e211ed045cb9cc9e7 (diff)
downloadaur-b11f4e3ea637841359c070f72bc1ad077b7fb80e.tar.gz
Update to 6.30.223.271-12
-rw-r--r--.SRCINFO14
-rw-r--r--003-linux47.patch109
-rw-r--r--PKGBUILD17
-rw-r--r--broadcom-wl-ck.install2
4 files changed, 129 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b46a6c088d4..3ebe5feb4349 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Thu May 5 00:03:33 UTC 2016
+# Sat Jun 25 15:28:24 UTC 2016
pkgbase = broadcom-wl-ck
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.
pkgver = 6.30.223.271
- pkgrel = 11
+ pkgrel = 12
url = http://www.broadcom.com/support/802.11/linux_sta.php
install = broadcom-wl-ck.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-ck-headers>=4.5
- makedepends = linux-ck-headers<4.6
- depends = linux-ck>=4.5
- depends = linux-ck<4.6
+ makedepends = linux-ck-headers>=4.6
+ makedepends = linux-ck-headers<4.7
+ depends = linux-ck>=4.6
+ depends = linux-ck<4.7
conflicts = broadcom-wl-ck-atom
conflicts = broadcom-wl-ck-barcelona
conflicts = broadcom-wl-ck-bulldozer
@@ -34,10 +34,12 @@ pkgbase = broadcom-wl-ck
source = license.patch
source = 001-null-pointer-fix.patch
source = 002-rdtscl.patch
+ source = 003-linux47.patch
sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
sha256sums = 2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac
sha256sums = 32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f
sha256sums = 29929989d86fde903f98419ce52dbb1d862cd4a11b0b13b2432886eeb6daabea
+ sha256sums = 30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e
source_i686 = http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-6_30_223_271.tar.gz
sha256sums_i686 = 4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd
source_x86_64 = http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz
diff --git a/003-linux47.patch b/003-linux47.patch
new file mode 100644
index 000000000000..566680a09140
--- /dev/null
+++ b/003-linux47.patch
@@ -0,0 +1,109 @@
+Since Linux 4.7, the enum ieee80211_band is no longer used
+
+This shall cause no problem's since both enums ieee80211_band
+and nl80211_band were added in the same commit:
+https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=13ae75b103e07304a34ab40c9136e9f53e06475c
+
+This patch refactors the references of IEEE80211_BAND_* to NL80211_BAND_*
+
+Reference:
+https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=57fbcce37be7c1d2622b56587c10ade00e96afa3
+
+--- a/src/wl/sys/wl_cfg80211_hybrid.c 2016-06-13 11:57:36.159340297 -0500
++++ b/src/wl/sys/wl_cfg80211_hybrid.c 2016-06-13 11:58:18.442323435 -0500
+@@ -236,7 +236,7 @@
+ #endif
+
+ #define CHAN2G(_channel, _freq, _flags) { \
+- .band = IEEE80211_BAND_2GHZ, \
++ .band = NL80211_BAND_2GHZ, \
+ .center_freq = (_freq), \
+ .hw_value = (_channel), \
+ .flags = (_flags), \
+@@ -245,7 +245,7 @@
+ }
+
+ #define CHAN5G(_channel, _flags) { \
+- .band = IEEE80211_BAND_5GHZ, \
++ .band = NL80211_BAND_5GHZ, \
+ .center_freq = 5000 + (5 * (_channel)), \
+ .hw_value = (_channel), \
+ .flags = (_flags), \
+@@ -379,7 +379,7 @@
+ };
+
+ static struct ieee80211_supported_band __wl_band_2ghz = {
+- .band = IEEE80211_BAND_2GHZ,
++ .band = NL80211_BAND_2GHZ,
+ .channels = __wl_2ghz_channels,
+ .n_channels = ARRAY_SIZE(__wl_2ghz_channels),
+ .bitrates = wl_g_rates,
+@@ -387,7 +387,7 @@
+ };
+
+ static struct ieee80211_supported_band __wl_band_5ghz_a = {
+- .band = IEEE80211_BAND_5GHZ,
++ .band = NL80211_BAND_5GHZ,
+ .channels = __wl_5ghz_a_channels,
+ .n_channels = ARRAY_SIZE(__wl_5ghz_a_channels),
+ .bitrates = wl_a_rates,
+@@ -395,7 +395,7 @@
+ };
+
+ static struct ieee80211_supported_band __wl_band_5ghz_n = {
+- .band = IEEE80211_BAND_5GHZ,
++ .band = NL80211_BAND_5GHZ,
+ .channels = __wl_5ghz_n_channels,
+ .n_channels = ARRAY_SIZE(__wl_5ghz_n_channels),
+ .bitrates = wl_a_rates,
+@@ -1876,8 +1876,8 @@
+ wdev->wiphy->max_num_pmkids = WL_NUM_PMKIDS_MAX;
+ #endif
+ wdev->wiphy->interface_modes = BIT(NL80211_IFTYPE_STATION) | BIT(NL80211_IFTYPE_ADHOC);
+- wdev->wiphy->bands[IEEE80211_BAND_2GHZ] = &__wl_band_2ghz;
+- wdev->wiphy->bands[IEEE80211_BAND_5GHZ] = &__wl_band_5ghz_a;
++ wdev->wiphy->bands[NL80211_BAND_2GHZ] = &__wl_band_2ghz;
++ wdev->wiphy->bands[NL80211_BAND_5GHZ] = &__wl_band_5ghz_a;
+ wdev->wiphy->signal_type = CFG80211_SIGNAL_TYPE_MBM;
+ wdev->wiphy->cipher_suites = __wl_cipher_suites;
+ wdev->wiphy->n_cipher_suites = ARRAY_SIZE(__wl_cipher_suites);
+@@ -2000,7 +2000,7 @@
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 39)
+ freq = ieee80211_channel_to_frequency(notif_bss_info->channel,
+ (notif_bss_info->channel <= CH_MAX_2G_CHANNEL) ?
+- IEEE80211_BAND_2GHZ : IEEE80211_BAND_5GHZ);
++ NL80211_BAND_2GHZ : NL80211_BAND_5GHZ);
+ #else
+ freq = ieee80211_channel_to_frequency(notif_bss_info->channel);
+ #endif
+@@ -2116,7 +2116,7 @@
+ return err;
+ }
+ chan = wf_chspec_ctlchan(chanspec);
+- band = (chan <= CH_MAX_2G_CHANNEL) ? IEEE80211_BAND_2GHZ : IEEE80211_BAND_5GHZ;
++ band = (chan <= CH_MAX_2G_CHANNEL) ? NL80211_BAND_2GHZ : NL80211_BAND_5GHZ;
+ freq = ieee80211_channel_to_frequency(chan, band);
+ channel = ieee80211_get_channel(wiphy, freq);
+ cfg80211_ibss_joined(ndev, (u8 *)&wl->bssid, channel, GFP_KERNEL);
+@@ -2250,10 +2250,10 @@
+ join_params->params.chanspec_list[0] =
+ ieee80211_frequency_to_channel(chan->center_freq);
+
+- if (chan->band == IEEE80211_BAND_2GHZ) {
++ if (chan->band == NL80211_BAND_2GHZ) {
+ chanspec |= WL_CHANSPEC_BAND_2G;
+ }
+- else if (chan->band == IEEE80211_BAND_5GHZ) {
++ else if (chan->band == NL80211_BAND_5GHZ) {
+ chanspec |= WL_CHANSPEC_BAND_5G;
+ }
+ else {
+@@ -2885,7 +2885,7 @@
+
+ if (phy == 'n' || phy == 'a' || phy == 'v') {
+ wiphy = wl_to_wiphy(wl);
+- wiphy->bands[IEEE80211_BAND_5GHZ] = &__wl_band_5ghz_n;
++ wiphy->bands[NL80211_BAND_5GHZ] = &__wl_band_5ghz_n;
+ }
+
+ return err;
diff --git a/PKGBUILD b/PKGBUILD
index 0d9837e821ee..a15e4fa34b6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,35 @@
# Maintainer: Armin K. <krejzi at email dot com>
# Contributor: Austin ( doorknob60 [at] gmail [dot] com )
# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: USA-RedDragon (AUR)
pkgname=broadcom-wl-ck
pkgver=6.30.223.271
-pkgrel=11
+pkgrel=12
_pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.'
-_extramodules="extramodules-4.5-ck"
+_extramodules="extramodules-4.6-ck"
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
pkgdesc="${_pkgdesc}"
arch=('i686' 'x86_64')
url='http://www.broadcom.com/support/802.11/linux_sta.php'
license=('custom')
-depends=('linux-ck>=4.5' 'linux-ck<4.6')
-makedepends=('linux-ck-headers>=4.5' 'linux-ck-headers<4.6')
+depends=('linux-ck>=4.6' 'linux-ck<4.7')
+makedepends=('linux-ck-headers>=4.6' 'linux-ck-headers<4.7')
conflicts=('broadcom-wl-ck-atom' 'broadcom-wl-ck-barcelona' 'broadcom-wl-ck-bulldozer' 'broadcom-wl-ck-corex' 'broadcom-wl-ck-core2' 'broadcom-wl-ck-haswell' 'broadcom-wl-ck-broadwell' 'broadcom-wl-ck-skylake' 'broadcom-wl-ck-ivybridge' 'broadcom-wl-ck-kx' 'broadcom-wl-ck-k10' 'broadcom-wl-ck-nehalem' 'broadcom-wl-ck-p4' 'broadcom-wl-ck-piledriver' 'broadcom-wl-ck-pentm' 'broadcom-wl-ck-sandybridge' 'broadcom-wl-ck-silvermont')
#replaces=()
#groups=('ck-generic')
source=('modprobe.d'
'license.patch'
'001-null-pointer-fix.patch'
-'002-rdtscl.patch')
+'002-rdtscl.patch'
+'003-linux47.patch')
source_i686+=("http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
source_x86_64+=("http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz")
sha256sums=('b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32'
'2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac'
'32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f'
- '29929989d86fde903f98419ce52dbb1d862cd4a11b0b13b2432886eeb6daabea')
+ '29929989d86fde903f98419ce52dbb1d862cd4a11b0b13b2432886eeb6daabea'
+ '30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e')
sha256sums_i686=('4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd')
sha256sums_x86_64=('5f79774d5beec8f7636b59c0fb07a03108eef1e3fd3245638b20858c714144be')
@@ -36,6 +39,8 @@ install=broadcom-wl-ck.install
prepare() {
patch -p1 -i license.patch
patch -p1 -i 001-null-pointer-fix.patch
+ patch -p1 -i 003-linux47.patch
+
sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
# linux 4.3 on i686 needs this to build
diff --git a/broadcom-wl-ck.install b/broadcom-wl-ck.install
index 431b87add7df..219e21a6eefe 100644
--- a/broadcom-wl-ck.install
+++ b/broadcom-wl-ck.install
@@ -1,5 +1,5 @@
post_upgrade() {
- EXTRAMODULES='extramodules-4.5-ck'
+ EXTRAMODULES='extramodules-4.6-ck'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}