summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCubeTheThird2021-02-07 21:21:59 -0500
committerCubeTheThird2021-02-07 21:21:59 -0500
commit7e80be264f355dea910970fe9118eda5f6035a54 (patch)
treef0c653fa55814a8cb12d1c1681128e466af40684
parent8f4209a8dd4684f4dc099900330abc31f6f22ea8 (diff)
downloadaur-7e80be264f355dea910970fe9118eda5f6035a54.tar.gz
Update version function to better match build version.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00ea3e547062..2a6768832be3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = brogue-ce-git
pkgdesc = Brogue Community Edition: A 26-level dungeon crawl to the Amulet of Yendor.
- pkgver = 1.8.1.r22.gceb03e6
+ pkgver = 1.9.4.19.dev.5e87eb6.master
pkgrel = 1
url = https://github.com/tmewett/BrogueCE
arch = i686
arch = x86_64
license = AGPL3
- makedepends = git
depends = sdl2_image
source = brogue-ce-git::git+https://github.com/tmewett/BrogueCE.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c936cf0bad24..75cfdb25e9bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
#Maintainer: CubeTheThird <cubethethird@gmail.com>
pkgname=brogue-ce-git
-pkgver=1.8.1.r26.g6979fcb
+pkgver=1.9.4.r19.dev.5e87eb6
pkgrel=1
pkgdesc="Brogue Community Edition: A 26-level dungeon crawl to the Amulet of Yendor."
arch=('i686' 'x86_64')
url="https://github.com/tmewett/BrogueCE"
license=('AGPL3')
depends=('sdl2_image')
-makedepends=('git')
source=(brogue-ce-git::"git+https://github.com/tmewett/BrogueCE.git")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
-git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+VER=$(grep "BROGUE_VERSION_STRING" src/brogue/Rogue.h | grep -o '[0-9.]\{1,\}')
+REV="$(git rev-list $(git describe --abbrev=0)..HEAD --count)"
+EXT="dev.$(git log -1 --format='%h')"
+echo ${VER}.r${REV}.${EXT}
}
build() {