summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2017-02-11 20:40:41 +0100
committerJulien Nicoulaud2017-02-11 20:40:46 +0100
commit16963e0b97a7edb09ed32c870dbb2db7476c51a2 (patch)
treea2b83c9af49c4245e5fd99cceb6b4684b85606f2
downloadaur-16963e0b97a7edb09ed32c870dbb2db7476c51a2.tar.gz
broom 1.6.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--Changelog10
-rw-r--r--PKGBUILD25
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c89df7486bf7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = broom
+ pkgdesc = A disk cleaning utility for developers.
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/nicoulaj/broom
+ changelog = Changelog
+ arch = any
+ license = MIT
+ depends = bash>=4
+ depends = ncurses
+ conflicts = broom-git
+ source = https://github.com/nicoulaj/broom/archive/1.6.0.tar.gz
+ md5sums = b82a814cea04afa4d7419f4def843a97
+
+pkgname = broom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..65aac6741ea6
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,10 @@
+2017-02-17 Julien Nicoulaud <julien.nicoulaud@gmail.com>
+
+ * 1.6.0-1 :
+ Initial release of the package.
+
+2012-01-21 Julien Nicoulaud <julien.nicoulaud@gmail.com>
+
+ * 1.0.0-1 :
+ Initial release of the package.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..036c3d6ad25f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+# Source: https://github.com/nicoulaj/archlinux-packages
+pkgname=broom
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="A disk cleaning utility for developers."
+arch=(any)
+url="https://github.com/nicoulaj/broom"
+license=(MIT)
+depends=(make perl)
+depends=('bash>=4' ncurses)
+changelog=Changelog
+conflicts=(${pkgname}-git)
+source=("https://github.com/nicoulaj/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('b82a814cea04afa4d7419f4def843a97')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make install DESTDIR="${pkgdir}" || return 1
+}