summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswearchnick2015-06-09 15:08:52 +0200
committerswearchnick2015-06-09 15:08:52 +0200
commit828806fc1faeb4ff1de22549ebb600bbcb3a6de0 (patch)
treec82fac646fce29b8d962b019d03e1cc7ce41f418
downloadaur-828806fc1faeb4ff1de22549ebb600bbcb3a6de0.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
-rw-r--r--brother_lpdwrapper_BrGenML1.patch23
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec1e87a9c522
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = brother-brgenml1
+ pkgdesc = LPR and CUPS driver for various Brother DCP, HL and MFC models. Complete list in package.
+ pkgver = 3.1.0_1
+ pkgrel = 2
+ url = http://support.brother.com/g/s/id/linux/en
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ source = http://download.brother.com/welcome/dlf101124/brgenml1lpr-3.1.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101126/brgenml1cupswrapper-3.1.0-1.i386.rpm
+ source = brother_lpdwrapper_BrGenML1.patch
+ md5sums = 9ab1b4096a3258ef3498377ce0a76d82
+ md5sums = cdba9c13be7a39ad75daa575f7cdf76e
+ md5sums = 2ada870167986ea8e55b61c6be0d5201
+
+pkgname = brother-brgenml1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..851089759290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: swearchnick <swearchnick[at]gmail[dot]com>
+
+pkgname=brother-brgenml1
+pkgver=3.1.0_1
+pkgrel=2
+_brotherpkgver=${pkgver:0:$((${#pkgver}-2))}
+_brotherrelease=${pkgver:$((${#pkgver}-1))}
+_brotherdrivername=BrGenML1
+pkgdesc="LPR and CUPS driver for various Brother DCP, HL and MFC models. Complete list in package."
+arch=('i686' 'x86_64')
+url='http://support.brother.com/g/s/id/linux/en'
+license=('GPL')
+depends=('cups')
+source=("http://download.brother.com/welcome/dlf101124/brgenml1lpr-${_brotherpkgver}-${_brotherrelease}.i386.rpm"
+ "http://download.brother.com/welcome/dlf101126/brgenml1cupswrapper-${_brotherpkgver}-${_brotherrelease}.i386.rpm"
+ "brother_lpdwrapper_${_brotherdrivername}.patch")
+
+md5sums=('9ab1b4096a3258ef3498377ce0a76d82'
+ 'cdba9c13be7a39ad75daa575f7cdf76e'
+ '2ada870167986ea8e55b61c6be0d5201')
+
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glibc')
+fi
+
+prepare() {
+
+patch "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}" < "$srcdir/brother_lpdwrapper_${_brotherdrivername}.patch"
+
+}
+
+package() {
+
+cp -a "$srcdir/var" "$pkgdir"
+
+install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother-${_brotherdrivername}-cups-en.ppd" "$pkgdir/usr/share/cups/model/brother-${_brotherdrivername}-cups-en.ppd"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${_brotherdrivername}"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/paperconfigml1" "$pkgdir/usr/share/Brother/Printer/$_brotherdrivername/cupswrapper/paperconfigml1"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/braddprinter" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/braddprinter"
+install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/br${_brotherdrivername}func" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/br${_brotherdrivername}func"
+install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/br${_brotherdrivername}rc" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/br${_brotherdrivername}rc"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/setupPrintcap" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/setupPrintcap"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/brprintconflsr3" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/brprintconflsr3"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/filter_${_brotherdrivername}" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/filter_${_brotherdrivername}"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/rawtobr3" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/rawtobr3"
+
+mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+
+echo "Compatible Model" > "$pkgdir/usr/share/doc/$pkgname/README"
+echo "DCP-7055, DCP-7055W, DCP-7060D, DCP-7065DN, DCP-7070DW, DCP-8070D, DCP-8085DN, DCP-8110DN, DCP-8250DN, HL-2130, HL-2132, HL-2135W, HL-2240, HL-2240D, HL-2250DN, HL-2270DW, HL-5340D, HL-5350DN, HL-5350DNLT, HL-5370DW, HL-5440D, HL-5450DN, HL-5450DNT, HL-5470DW, HL-6180DW, HL-6180DWT, MFC-7360N, MFC-7460DN, MFC-7860DW, MFC-8370DN, MFC-8510DN, MFC-8520DN, MFC-8880DN, MFC-8890DW, MFC-8950DW, MFC-8950DWT" >> "$pkgdir/usr/share/doc/$pkgname/README"
+
+chmod 0644 "$pkgdir/usr/share/doc/$pkgname/README"
+
+}
diff --git a/brother_lpdwrapper_BrGenML1.patch b/brother_lpdwrapper_BrGenML1.patch
new file mode 100644
index 000000000000..c594275c3c8a
--- /dev/null
+++ b/brother_lpdwrapper_BrGenML1.patch
@@ -0,0 +1,23 @@
+53,54c53,55
+< $basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
+<
+---
+> #$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
+> my $PRINTER = "BrGenML1";
+> my $basedir = "/usr/share/Brother/Printer/$PRINTER";
+80c81
+< my $PRINTER=$basedir;
+---
+> #my $PRINTER=$basedir;
+87,89c88,90
+< $PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+< $PRINTER =~ s/\/cupswrapper//g;
+< $PRINTER =~ s/\///g;
+---
+> #$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+> #$PRINTER =~ s/\/cupswrapper//g;
+> #$PRINTER =~ s/\///g;
+736c737
+< $lpddir = $basedir."/lpd/";
+---
+> $lpddir = $basedir."/lpd";