summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswearchnick2016-08-12 18:07:23 +0200
committerswearchnick2016-08-12 18:07:23 +0200
commitc6dbe4034ebdb517aac7439f124f095286f2405b (patch)
treeae182f7d9160a7835e9fe6058291c6d82f555f90
parent828806fc1faeb4ff1de22549ebb600bbcb3a6de0 (diff)
downloadaur-c6dbe4034ebdb517aac7439f124f095286f2405b.tar.gz
Corrected license and modernized PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
-rw-r--r--lpr-license.txt9
3 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec1e87a9c522..f12084f9c28d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = brother-brgenml1
- pkgdesc = LPR and CUPS driver for various Brother DCP, HL and MFC models. Complete list in package.
+ pkgdesc = LPR and CUPS driver for various Brother DCP, HL and MFC models.
pkgver = 3.1.0_1
- pkgrel = 2
+ pkgrel = 3
url = http://support.brother.com/g/s/id/linux/en
arch = i686
arch = x86_64
- license = GPL
+ license = GPL version 2 for CUPS driver, custom:brother commercial license for LPR driver.
depends = cups
+ depends = lib32-glibc
source = http://download.brother.com/welcome/dlf101124/brgenml1lpr-3.1.0-1.i386.rpm
source = http://download.brother.com/welcome/dlf101126/brgenml1cupswrapper-3.1.0-1.i386.rpm
- source = brother_lpdwrapper_BrGenML1.patch
+ source = lpr-license.txt
md5sums = 9ab1b4096a3258ef3498377ce0a76d82
md5sums = cdba9c13be7a39ad75daa575f7cdf76e
- md5sums = 2ada870167986ea8e55b61c6be0d5201
+ md5sums = dbf216d89fbc0c287c569d819a1bca51
pkgname = brother-brgenml1
diff --git a/PKGBUILD b/PKGBUILD
index 851089759290..580c7ca13f85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,35 @@
pkgname=brother-brgenml1
pkgver=3.1.0_1
-pkgrel=2
+pkgrel=3
_brotherpkgver=${pkgver:0:$((${#pkgver}-2))}
_brotherrelease=${pkgver:$((${#pkgver}-1))}
_brotherdrivername=BrGenML1
-pkgdesc="LPR and CUPS driver for various Brother DCP, HL and MFC models. Complete list in package."
+pkgdesc="LPR and CUPS driver for various Brother DCP, HL and MFC models."
arch=('i686' 'x86_64')
url='http://support.brother.com/g/s/id/linux/en'
-license=('GPL')
+license=('GPL version 2 for CUPS driver, custom:brother commercial license for LPR driver.')
depends=('cups')
+depends_x86_64=('lib32-glibc')
source=("http://download.brother.com/welcome/dlf101124/brgenml1lpr-${_brotherpkgver}-${_brotherrelease}.i386.rpm"
"http://download.brother.com/welcome/dlf101126/brgenml1cupswrapper-${_brotherpkgver}-${_brotherrelease}.i386.rpm"
- "brother_lpdwrapper_${_brotherdrivername}.patch")
+ "lpr-license.txt")
md5sums=('9ab1b4096a3258ef3498377ce0a76d82'
'cdba9c13be7a39ad75daa575f7cdf76e'
- '2ada870167986ea8e55b61c6be0d5201')
-
-if [[ "$CARCH" == "x86_64" ]]; then
- depends+=('lib32-glibc')
-fi
+ 'dbf216d89fbc0c287c569d819a1bca51')
prepare() {
-patch "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}" < "$srcdir/brother_lpdwrapper_${_brotherdrivername}.patch"
+sed -i 's/\$basedir =~ s\/$PRINTER\\\/cupswrapper\\\/.\*\$\/$PRINTER\\\/\/g;/my \$PRINTER = \"BrGenML1\";\nmy \$basedir = \"\/usr\/share\/Brother\/Printer\/\$PRINTER\";/' "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}"
+
+sed -i '/my \$PRINTER=\$basedir;/d' "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}"
+
+sed -i '/\$PRINTER =\~ s\/\^\\\/opt\\\/.\*\\\/Printers\\\/\/\/g;/d' "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}"
+sed -i '/\$PRINTER =\~ s\/\\\/cupswrapper\/\/g;/d' "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}"
+sed -i '/\$PRINTER =\~ s\/\\\/\/\/g;/d' "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}"
+
+sed -i 's/\$lpddir = \$basedir.\"\/lpd\/";/\$lpddir = \$basedir.\"\/lpd\";/' "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}"
}
@@ -37,7 +42,7 @@ install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/b
install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${_brotherdrivername}"
-install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/paperconfigml1" "$pkgdir/usr/share/Brother/Printer/$_brotherdrivername/cupswrapper/paperconfigml1"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/paperconfigml1" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/cupswrapper/paperconfigml1"
install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/braddprinter" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/braddprinter"
install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/br${_brotherdrivername}func" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/br${_brotherdrivername}func"
@@ -48,11 +53,6 @@ install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/brprintco
install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/filter_${_brotherdrivername}" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/filter_${_brotherdrivername}"
install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/rawtobr3" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/rawtobr3"
-mkdir -p "$pkgdir/usr/share/doc/$pkgname"
-
-echo "Compatible Model" > "$pkgdir/usr/share/doc/$pkgname/README"
-echo "DCP-7055, DCP-7055W, DCP-7060D, DCP-7065DN, DCP-7070DW, DCP-8070D, DCP-8085DN, DCP-8110DN, DCP-8250DN, HL-2130, HL-2132, HL-2135W, HL-2240, HL-2240D, HL-2250DN, HL-2270DW, HL-5340D, HL-5350DN, HL-5350DNLT, HL-5370DW, HL-5440D, HL-5450DN, HL-5450DNT, HL-5470DW, HL-6180DW, HL-6180DWT, MFC-7360N, MFC-7460DN, MFC-7860DW, MFC-8370DN, MFC-8510DN, MFC-8520DN, MFC-8880DN, MFC-8890DW, MFC-8950DW, MFC-8950DWT" >> "$pkgdir/usr/share/doc/$pkgname/README"
-
-chmod 0644 "$pkgdir/usr/share/doc/$pkgname/README"
+install -Dm644 lpr-license.txt "$pkgdir/usr/share/licenses/$pkgname/lpr-licence.txt"
}
diff --git a/lpr-license.txt b/lpr-license.txt
new file mode 100644
index 000000000000..097d00dfdf03
--- /dev/null
+++ b/lpr-license.txt
@@ -0,0 +1,9 @@
+License Agreement
+
+This Agreement provides terms and conditions for license grant from Brother Industries, Ltd ("Broher"). Brother, who owns all copyrights to the software that is distributed with this Agreement ("Software") to recipients thereof ("User"), for use of the Software. User shall have the right to use the Software only in accordance with the terms and conditions of this Agreement. Any use by User of the Software shall be deemed as its agreement hereto.
+
+Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.
+
+Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.
+
+The license of the Software from Brother hereunder is granted "AS IS." BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT. Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage. Further, Brother shall have no liability to disclose and/or distribute the source cord of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother's implied agreement or undertakings to disclose and/or distribute the source cord of the Software.