summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2017-04-26 19:59:54 +0200
committerRicardo Band2017-04-26 19:59:54 +0200
commit7efd3159ff2275aadc03e998eaf1d7897e69f93c (patch)
tree413c6c7408bb59de8d7fc7269166d9f8a5d83186
parent07051f69e0ec892fa716d2463310967aff620fb6 (diff)
downloadaur-7efd3159ff2275aadc03e998eaf1d7897e69f93c.tar.gz
cups wrapper updated to 1.1.4-0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85129188f960..9d0b14134e02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
-# Generated by mksrcinfo v8
-# Wed Jul 27 23:41:55 UTC 2016
pkgbase = brother-dcp-9022cdw
pkgdesc = LPR and CUPS driver for the Brother DCP-9022CDW
pkgver = 1.1.3
- pkgrel = 2
+ pkgrel = 3
url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
install = brother-dcp-9022cdw.install
arch = i686
arch = x86_64
license = unknown
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ depends = lib32-glibc
source = http://download.brother.com/welcome/dlf101612/dcp9022cdwlpr-1.1.3-0.i386.deb
- source = http://download.brother.com/welcome/dlf101613/dcp9022cdwcupswrapper-1.1.3-0.i386.deb
+ source = http://download.brother.com/welcome/dlf101613/dcp9022cdwcupswrapper-1.1.4-0.i386.deb
sha256sums = 8db48cda7e8f38f6a9fe0279f67e6d286a300f41e7982d1be275113542ec5027
- sha256sums = 469a31e8b2327e927a92a57635e079e504a87e864b0e51b1223fd4c184184ba6
+ sha256sums = 5b44c91152236079ebfd15f5b0e1e8f515d114a395cf77459387ba9358c8a7fa
pkgname = brother-dcp-9022cdw
diff --git a/PKGBUILD b/PKGBUILD
index 6346788bcf2a..0f9646b07cea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
_model="9022cdw"
pkgname="brother-dcp-$_model"
pkgver="1.1.3"
-pkgrel=2
-_revision=0
+pkgrel=3
+_lprver="1.1.3-0"
+_wrpver="1.1.4-0"
pkgdesc="LPR and CUPS driver for the Brother DCP-9022CDW"
url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
arch=('i686' 'x86_64')
@@ -15,20 +16,21 @@ if [[ "$CARCH" == "x86_64" ]] ; then
elif [[ "$CARCH" == "i686" ]] ; then
depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
fi
-source=("http://download.brother.com/welcome/dlf101612/dcp${_model}lpr-${pkgver}-${_revision}.i386.deb"
- "http://download.brother.com/welcome/dlf101613/dcp9022cdwcupswrapper-1.1.3-0.i386.deb")
+source=("http://download.brother.com/welcome/dlf101612/dcp${_model}lpr-${_lprver}.i386.deb"
+ "http://download.brother.com/welcome/dlf101613/dcp${_model}cupswrapper-${_wrpver}.i386.deb")
sha256sums=('8db48cda7e8f38f6a9fe0279f67e6d286a300f41e7982d1be275113542ec5027'
- '469a31e8b2327e927a92a57635e079e504a87e864b0e51b1223fd4c184184ba6')
+ '5b44c91152236079ebfd15f5b0e1e8f515d114a395cf77459387ba9358c8a7fa')
package() {
- deb2targz *.deb >/dev/null || return 1
- rm -f *.deb || return 1
- cd $srcdir || return 1
- [ -d "dcp${_model}" ] || (mkdir dcp${_model} || return 1)
- for i in *.tar.gz;do tar xfz $i -C dcp${_model};done || return 1
- cd dcp${_model} || return 1
- cd opt/brother/Printers/dcp${_model} || return 1
- perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrapperdcp${_model} || return 1
- perl -i -pe 's#printcap\.local#printcap#g' $srcdir/dcp${_model}/opt/brother/Printers/dcp${_model}/inf/setupPrintcapij || return 1
- cp -rf $srcdir/dcp${_model}/usr/ $pkgdir/ || return 1
- cp -rf $srcdir/dcp${_model}/opt/ $pkgdir/ || return 1
+ deb2targz *.deb >/dev/null
+ rm -f *.deb
+ cd $srcdir
+ mkdir dcp${_model}
+ for i in *.tar.gz ; do
+ tar xfz $i -C dcp${_model}
+ done
+ cd dcp${_model}/opt/brother/Printers/dcp${_model}
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrapperdcp${_model}
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/dcp${_model}/opt/brother/Printers/dcp${_model}/inf/setupPrintcapij
+ cp -rf $srcdir/dcp${_model}/usr/ $pkgdir/
+ cp -rf $srcdir/dcp${_model}/opt/ $pkgdir/
}