summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Maciej Nowak2016-04-05 17:04:34 +0200
committerTomasz Maciej Nowak2016-04-05 17:04:34 +0200
commitfb03ec9c0e66782189e164640bc52ddf10c86d30 (patch)
tree643574f1dfa187ec6a9579053f2bc71c5a16a75b
downloadaur-fb03ec9c0e66782189e164640bc52ddf10c86d30.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
-rw-r--r--basedir.patch17
-rw-r--r--brother-dcp-l2500d.install6
-rw-r--r--eula.txt8
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a71a12ec1e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Apr 5 15:01:11 UTC 2016
+pkgbase = brother-dcp-l2500d
+ pkgdesc = LPR and CUPS driver for the Brother DCP-L2500D
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://solutions.brother.com/linux
+ install = brother-dcp-l2500d.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom:Brother EULA
+ depends = cups
+ source = http://download.brother.com/welcome/dlf101753/dcpl2500dlpr-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101754/dcpl2500dcupswrapper-3.2.0-1.i386.rpm
+ source = basedir.patch
+ source = eula.txt
+ sha256sums = ec739bb742cb16f943e5faeed845b317ff6608229b4826c8738e5076f90e810e
+ sha256sums = d53d13a0854f8a8fd50bdbaf3fe2edead7c52d17f11bb86c64d000d5ffd28aef
+ sha256sums = baf435d197594de95193e2b08eaa4a8c071fc86ce2b98d84f6e83d0f6bcac293
+ sha256sums = d1c2d3abdcbcb3f5251fb8109d4b9eff0fba9707ae6697601d75bead71d7ffd4
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-dcp-l2500d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cddee38517ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tomasz Maciej Nowak <com[dot]gmail[at]tmn505>
+# patch idea taken from package brother-hl-l2380dw by apaugh
+pkgname=brother-dcp-l2500d
+pkgver=3.2.0_1
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother DCP-L2500D"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux"
+license=('GPL2' 'custom:Brother EULA')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+install=${pkgname}.install
+source=("http://download.brother.com/welcome/dlf101753/dcpl2500dlpr-${pkgver/_/-}.i386.rpm"
+ "http://download.brother.com/welcome/dlf101754/dcpl2500dcupswrapper-${pkgver/_/-}.i386.rpm"
+ 'basedir.patch'
+ 'eula.txt')
+sha256sums=('ec739bb742cb16f943e5faeed845b317ff6608229b4826c8738e5076f90e810e'
+ 'd53d13a0854f8a8fd50bdbaf3fe2edead7c52d17f11bb86c64d000d5ffd28aef'
+ 'baf435d197594de95193e2b08eaa4a8c071fc86ce2b98d84f6e83d0f6bcac293'
+ 'd1c2d3abdcbcb3f5251fb8109d4b9eff0fba9707ae6697601d75bead71d7ffd4')
+
+prepare() {
+ patch -p0 -i ${srcdir}/basedir.patch
+}
+
+package() {
+ cp -R ${srcdir}/opt ${pkgdir}
+ rm ${pkgdir}/opt/brother/Printers/DCPL2500D/cupswrapper/Copying
+ install -Dm644 ${srcdir}/eula.txt ${pkgdir}/usr/share/licenses/${pkgname}/eula.txt
+ ln -s /usr/share/licenses/GPL2/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/cupswrapper-license.txt
+ install -dm755 ${pkgdir}/usr/share/cups/model
+ ln -s /opt/brother/Printers/DCPL2500D/cupswrapper/brother-DCPL2500D-cups-en.ppd ${pkgdir}/usr/share/cups/model/brother-DCPL2500D-cups-en.ppd
+ install -dm755 ${pkgdir}/usr/lib/cups/filter
+ ln -s /opt/brother/Printers/DCPL2500D/cupswrapper/brother_lpdwrapper_DCPL2500D ${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_DCPL2500D
+}
diff --git a/basedir.patch b/basedir.patch
new file mode 100644
index 000000000000..8f71b8bb94ac
--- /dev/null
+++ b/basedir.patch
@@ -0,0 +1,17 @@
+--- opt/brother/Printers/DCPL2500D/cupswrapper/brother_lpdwrapper_DCPL2500D.orig 2014-09-29 10:02:44.000000000 +0200
++++ opt/brother/Printers/DCPL2500D/cupswrapper/brother_lpdwrapper_DCPL2500D 2016-04-04 00:39:29.552531316 +0200
+@@ -44,13 +44,7 @@ $width=-1;
+ $height=-1;
+
+ #my $basedir = Cwd::realpath ($0);
+-my $basedir = `readlink $0`;
+-if ( $basedir eq '' ){
+- $basedir = `realpath $0`;
+-}
+-chomp($basedir);
+-
+-$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
++my $basedir = "/opt/brother/Printers/DCPL2500D";
+
+
+ %units = ( pt => \&pt2dot,
diff --git a/brother-dcp-l2500d.install b/brother-dcp-l2500d.install
new file mode 100644
index 000000000000..60cab9fe48a7
--- /dev/null
+++ b/brother-dcp-l2500d.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo ">> After installation restart CUPS server."
+ echo ">> It might be necessary to add udev rules mentioned in:"
+ echo ">> https://wiki.archlinux.org/index.php/CUPS/Troubleshooting#Printer_is_not_recognized_by_CUPS."
+ echo ">> If You had to do that, please leave comment on AUR, I'll provide the rule with the package."
+}
diff --git a/eula.txt b/eula.txt
new file mode 100644
index 000000000000..094108f7c31f
--- /dev/null
+++ b/eula.txt
@@ -0,0 +1,8 @@
+License Agreement
+This Agreement provides terms and conditions for license grant from Brother Industries, Ltd ("Broher"). Brother, who owns all copyrights to the software that is distributed with this Agreement ("Software") to recipients thereof ("User"), for use of the Software. User shall have the right to use the Software only in accordance with the terms and conditions of this Agreement. Any use by User of the Software shall be deemed as its agreement hereto.
+
+Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.
+
+Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.
+
+The license of the Software from Brother hereunder is granted "AS IS." BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT. Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage. Further, Brother shall have no liability to disclose and/or distribute the source cord of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother's implied agreement or undertakings to disclose and/or distribute the source cord of the Software.