summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie2020-06-08 20:17:37 -0400
committerJamie2020-06-08 20:17:37 -0400
commitc765bb1870e1ed745f61d6c1a80da43cb338adcb (patch)
treea88410f27216c479b8a9aebfb681b1dc9e780f00
downloadaur-c765bb1870e1ed745f61d6c1a80da43cb338adcb.tar.gz
initial release version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed6bc0b8f7c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = brother-dcp-l2550dw
+ pkgdesc = LPR and CUPS driver for the Brother DCP-L2550DW printer
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://support.brother.com/g/b/downloadhowto.aspx?c=ca&lang=en&prod=dcpl2550dw_us&os=127&dlid=dlf103576_000&flang=4&type3=10282
+ arch = i686
+ arch = x86_64
+ groups = base-devel
+ license = EULA
+ source = https://download.brother.com/welcome/dlf103576/dcpl2550dwpdrv-4.0.0-1.i386.rpm
+ md5sums = 92279e64ec1e40714bb707ab9aab2600
+
+pkgname = brother-dcp-l2550dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22551c2c717b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=brother-dcp-l2550dw
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother DCP-L2550DW printer"
+arch=("i686" "x86_64")
+url="https://support.brother.com/g/b/downloadhowto.aspx?c=ca&lang=en&prod=dcpl2550dw_us&os=127&dlid=dlf103576_000&flang=4&type3=10282"
+license=("EULA")
+groups=("base-devel")
+source=("https://download.brother.com/welcome/dlf103576/dcpl2550dwpdrv-4.0.0-1.i386.rpm")
+md5sums=('92279e64ec1e40714bb707ab9aab2600')
+
+package() {
+ # This package is based off of the brother-mfc-l2710dw package due to the identical packaging. All credit should go to enginefeeder101 for the script.
+
+ _model="DCPL2550DW"
+
+ # using /usr/share instead of /opt
+ mkdir -p "$pkgdir/usr/share"
+ cp -R "$srcdir/opt/brother" "$pkgdir/usr/share"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/$_model/cupswrapper/lpdwrapper"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/$_model/lpd/lpdfilter"
+
+ # /etc/printcap is managed by cups
+ find "$pkgdir" -type f -name 'setupPrintcap*' -delete
+
+ # symlink for lpdwrapper so it correctly figures out the printer model from the path
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/$_model/cupswrapper/lpdwrapper" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_$_model"
+
+ # symlink for the PPD
+ install -d "$pkgdir/usr/share/cups/model/"
+ ln -s "/usr/share/brother/Printers/$_model/cupswrapper/brother-$_model-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
+
+ # a couple architecture-specific symlinks
+ ln -s "/usr/share/brother/Printers/$_model/lpd/$CARCH/brprintconflsr3" "$pkgdir/usr/share/brother/Printers/$_model/lpd/"
+ ln -s "/usr/share/brother/Printers/$_model/lpd/$CARCH/rawtobr3" "$pkgdir/usr/share/brother/Printers/$_model/lpd/"
+
+ # symlink for inf because it tries to execute it there
+ ln -s "/usr/share/brother/Printers/$_model/inf" "$pkgdir/usr/share/brother/Printers/$_model/lpd/"
+}