summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornyxkn2016-01-02 20:35:04 +0100
committernyxkn2016-01-02 20:35:04 +0100
commitc6cff443d3251ea4ae6b08cf3dd8d7e3c2d63e4b (patch)
tree8750edfbd698c0dd262ecc860df1b39e1f4144f9
downloadaur-c6cff443d3251ea4ae6b08cf3dd8d7e3c2d63e4b.tar.gz
Initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d67941a2cb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 2 19:27:46 UTC 2016
+pkgbase = brother-dcp1610w
+ pkgdesc = LPR and CUPS driver for the Brother DCP-1610W and DCP-1612W printers
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://support.brother.com/g/b/producttop.aspx?c=as_ot&lang=en&prod=dcp1610w_eu_as
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = cups
+ optdepends = brscan4: scanner support
+ source = http://download.brother.com/welcome/dlf101535/dcp1610wlpr-3.0.1-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101534/dcp1610wcupswrapper-3.0.1-1.i386.rpm
+ md5sums = 70075f1889548b81096cd944d0bfad76
+ md5sums = 8dd299667f27afc09f1fa5152669e04f
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-dcp1610w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6758e937b27e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: nyxkn <nyxkn [at] yahoo [dot] com>
+
+pkgname=brother-dcp1610w
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother DCP-1610W and DCP-1612W printers"
+arch=('i686' 'x86_64')
+url="http://support.brother.com/g/b/producttop.aspx?c=as_ot&lang=en&prod=dcp1610w_eu_as"
+license=('GPL2')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+optdepends=('brscan4: scanner support')
+source=(http://download.brother.com/welcome/dlf101535/dcp1610wlpr-3.0.1-1.i386.rpm
+ http://download.brother.com/welcome/dlf101534/dcp1610wcupswrapper-3.0.1-1.i386.rpm)
+md5sums=('70075f1889548b81096cd944d0bfad76'
+ '8dd299667f27afc09f1fa5152669e04f')
+
+package() {
+ # cp -r ${srcdir}/etc ${pkgdir}/
+ cp -r ${srcdir}/opt ${pkgdir}/
+ cp -r ${srcdir}/var ${pkgdir}/
+
+ mkdir -p ${pkgdir}/usr/share/cups/model
+ mkdir -p ${pkgdir}/usr/lib/cups/filter
+ ln -s /opt/brother/Printers/DCP1610W/cupswrapper/brother-DCP1610W-cups-en.ppd \
+ ${pkgdir}/usr/share/cups/model
+ ln -s /opt/brother/Printers/DCP1610W/cupswrapper/brother_lpdwrapper_DCP1610W \
+ ${pkgdir}/usr/lib/cups/filter
+}
+