summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Mueller2014-03-06 19:31:29 +0100
committerAaron Mueller2014-03-06 19:31:29 +0100
commit9b9cfe783f97f43e13c9e5756edd80dca0d8a2a7 (patch)
tree1b1f2b792363ccf139ab2b9cc8c234b74ec076f9
downloadaur-9b9cfe783f97f43e13c9e5756edd80dca0d8a2a7.tar.gz
Move all packages to version control
-rw-r--r--.SRCINFO29
-rw-r--r--DCP7030.ppd.gzbin0 -> 2426 bytes
-rw-r--r--PKGBUILD68
-rwxr-xr-xbrlpdwrapperDCP7030161
-rw-r--r--cupswrapper-systemd.patch57
5 files changed, 315 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7d037d42397
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = brother-dcp7030
+ pkgdesc = Brother cupd and lpd driver for DCP-7030
+ pkgver = 2.0.2
+ pkgrel = 3
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#DCP-7030
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = lib32-glibc
+ depends = psutils
+ noextract = DCP7030.ppd.gz
+ source = http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7030-2.0.2-1.i386.deb
+ source = http://www.brother.com/pub/bsc/linux/dlf/brdcp7030lpr-2.0.2-1.i386.deb
+ source = brlpdwrapperDCP7030
+ source = DCP7030.ppd.gz
+ source = cupswrapper-systemd.patch
+ md5sums = 73919884cb19f9fb1a462c77aaa3477e
+ md5sums = 26b48edf27afe34d9847579cd81eb206
+ md5sums = 993574b2c9e9052ae8d823d5414d8585
+ md5sums = 7cb25cc78f001c18e591504db90fe20f
+ md5sums = 567b9004776ab376f273181256165479
+ sha256sums = a9a4e0ec5f941cf17fcc7156febf8aff21673bc78a6313176527a0423847627d
+ sha256sums = cd4e6c4b16c5e734721068134699c65b2eca0584bc86031ee7eef7af05b36d8c
+ sha256sums = 0320e1f19c3be746442b7c6324f0732b17928d2bb611ef143007f6ca0882765b
+ sha256sums = ff55d56e1d4488768cbe3ca843a26a284bd2988bd9dddf4a0f1d39c637929997
+ sha256sums = 11bfa0871ec5fda4e49e8d768840ca0de8a5aa6e8aec740b0a42ef8bc9e53c8a
+
+pkgname = brother-dcp7030
+
diff --git a/DCP7030.ppd.gz b/DCP7030.ppd.gz
new file mode 100644
index 000000000000..64cc68eaa861
--- /dev/null
+++ b/DCP7030.ppd.gz
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9464e854c06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Aaron Mueller <mail@aaron-mueller.de>
+# Contributor: Andrej Gelenberg <andrej.gelenberg@udo.edu>
+
+pkgname=brother-dcp7030
+pkgver=2.0.2
+pkgrel=3
+pkgdesc="Brother cupd and lpd driver for DCP-7030"
+arch=('i686' 'x86_64')
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#DCP-7030"
+license=('custom')
+
+if [ "$(uname -m)" = "x86_64" ]; then
+ depends=('lib32-glibc' 'psutils')
+else
+ depends=('psutils')
+fi
+
+source=(http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7030-$pkgver-1.i386.deb
+ http://www.brother.com/pub/bsc/linux/dlf/brdcp7030lpr-$pkgver-1.i386.deb
+ brlpdwrapperDCP7030
+ DCP7030.ppd.gz
+ cupswrapper-systemd.patch)
+noextract=(DCP7030.ppd.gz)
+
+md5sums=('73919884cb19f9fb1a462c77aaa3477e'
+ '26b48edf27afe34d9847579cd81eb206'
+ '993574b2c9e9052ae8d823d5414d8585'
+ '7cb25cc78f001c18e591504db90fe20f'
+ '567b9004776ab376f273181256165479')
+sha256sums=('a9a4e0ec5f941cf17fcc7156febf8aff21673bc78a6313176527a0423847627d'
+ 'cd4e6c4b16c5e734721068134699c65b2eca0584bc86031ee7eef7af05b36d8c'
+ '0320e1f19c3be746442b7c6324f0732b17928d2bb611ef143007f6ca0882765b'
+ 'ff55d56e1d4488768cbe3ca843a26a284bd2988bd9dddf4a0f1d39c637929997'
+ '11bfa0871ec5fda4e49e8d768840ca0de8a5aa6e8aec740b0a42ef8bc9e53c8a')
+
+build() {
+ srcdir="$startdir/src"
+ mkdir -p "$srcdir" && cd "$srcdir"
+
+ for i in $startdir/*.deb; do
+ ar -x $i
+ bsdtar xf data.tar.gz
+ done
+
+ cat <<END >>$srcdir/usr/local/Brother/inf/brDCP7030func
+ [psconvert2]
+ pstops=/usr/bin/pstops
+END
+
+ patch $srcdir/usr/local/Brother/cupswrapper/cupswrapperDCP7030-2.0.2 < cupswrapper-systemd.patch
+}
+
+package() {
+ srcdir="$startdir/src"
+ cd $srcdir
+
+ cp -r "$srcdir/usr" "$pkgdir"
+ cp -r "$srcdir/var" "$pkgdir"
+
+ install -d -m755 "$pkgdir/usr/lib/cups/filter"
+ install -d -m755 "$pkgdir/usr/share/cups/model"
+ install -D -m755 "$startdir/brlpdwrapperDCP7030" "$pkgdir/usr/lib/cups/filter"
+ install -D -m644 "$startdir/DCP7030.ppd.gz" "$pkgdir/usr/share/cups/model"
+
+ # Clean up some stuff
+ rm "$pkgdir/usr/share/doc/cupswrapperdcp7030/changelog.Debian.gz"
+}
+
diff --git a/brlpdwrapperDCP7030 b/brlpdwrapperDCP7030
new file mode 100755
index 000000000000..9fb83594596c
--- /dev/null
+++ b/brlpdwrapperDCP7030
@@ -0,0 +1,161 @@
+#! /bin/sh
+#
+# Brother Print filter >> brlpdwrapperDCP7030
+# Copyright (C) 2005 Brother. Industries, Ltd.
+# Ver1.00
+
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the Free
+# Software Foundation; either version 2 of the License, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
+# more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
+# Place, Suite 330, Boston, MA 02111-1307 USA
+#
+LOGFILE="/dev/null"
+LOGCLEVEL="7"
+DEBUG=0
+NUPENABLE=1
+ENABLECOPY=0
+LOG_LATESTONLY=1
+errorcode=0
+
+set +o noclobber
+if [ "`echo $5 | grep 'debug-noprint=1'`" != '' ]; then
+ DEBUG=1
+fi
+if [ "`echo $5 | grep 'debug-noprint=2'`" != '' ]; then
+ DEBUG=2
+fi
+if [ "`echo $5 | grep 'debug-noprint=3'`" != '' ]; then
+ DEBUG=3
+fi
+if [ $DEBUG != 0 ]; then
+ LOGFILE=/tmp/br_cupsfilter_debug_log
+fi
+
+PRINTER=DCP7030
+
+
+if [ "$PPD" = "" ]; then
+ PPD="/usr/share/cups/model/DCP7030.ppd"
+fi
+
+
+if [ $LOGFILE != "/dev/null" ]; then
+ if [ $LOG_LATESTONLY == "1" ]; then
+ rm -f $LOGFILE
+ date >$LOGFILE
+ else
+ if [ -e $LOGFILE ]; then
+ date >>$LOGFILE
+ else
+ date >$LOGFILE
+ fi
+ fi
+ echo "arg0 = $0" >>$LOGFILE
+ echo "arg1 = $1" >>$LOGFILE
+ echo "arg2 = $2" >>$LOGFILE
+ echo "arg3 = $3" >>$LOGFILE
+ echo "arg4 = $4" >>$LOGFILE
+ echo "arg5 = $5" >>$LOGFILE
+ echo "arg6 = $6" >>$LOGFILE
+ echo "PPD = $PPD" >>$LOGFILE
+fi
+
+INPUT_TEMP_PS=`mktemp /tmp/br_input_ps.XXXXXX`
+
+nup="cat"
+if [ "`echo $5 | grep 'Nup='`" != '' ] && [ $NUPENABLE != 0 ]; then
+
+ if [ "`echo $5 | grep 'Nup=64'`" != '' ]; then
+ nup="psnup -64"
+ elif [ "`echo $5 | grep 'Nup=32'`" != '' ]; then
+ nup="psnup -32"
+ elif [ "`echo $5 | grep 'Nup=25'`" != '' ]; then
+ nup="psnup -25"
+ elif [ "`echo $5 | grep 'Nup=16'`" != '' ]; then
+ nup="psnup -16"
+ elif [ "`echo $5 | grep 'Nup=8'`" != '' ]; then
+ nup="psnup -8"
+ elif [ "`echo $5 | grep 'Nup=6'`" != '' ]; then
+ nup="psnup -6"
+ elif [ "`echo $5 | grep 'Nup=4'`" != '' ]; then
+ nup="psnup -4"
+ elif [ "`echo $5 | grep 'Nup=2'`" != '' ]; then
+ nup="psnup -2"
+ elif [ "`echo $5 | grep 'Nup=1'`" != '' ]; then
+ nup="cat"
+ fi
+ echo "NUP=$nup" >>$LOGFILE
+ if [ -e /usr/bin/psnup ]; then
+ if [ $# -ge 7 ]; then
+ cat $6 | $nup > $INPUT_TEMP_PS
+ else
+ cat | $nup > $INPUT_TEMP_PS
+ fi
+ else
+ if [ $# -ge 7 ]; then
+ cp $6 $INPUT_TEMP_PS
+ else
+ cat > $INPUT_TEMP_PS
+ fi
+ fi
+else
+ if [ $# -ge 7 ]; then
+ cp $6 $INPUT_TEMP_PS
+ else
+ cat > $INPUT_TEMP_PS
+ fi
+fi
+
+if [ "$ENABLECOPY" != 0 ];then
+ if [ "$4" -ge 2 ];then
+ options="$5"" ""Copies=$4"
+ else
+ options="$5"
+ fi
+else
+ options="$5"
+fi
+
+
+if [ -e "/usr/local/Brother/lpd/filter$PRINTER" ]; then
+ :
+else
+ echo "ERROR: /usr/local/Brother/lpd/filter$PRINTER does not exist" >>$LOGFILE
+ errorcode=30
+ exit $errorcode
+fi
+
+if [ -e "/usr/local/Brother/cupswrapper/brcupsconfig3" ]; then
+ if [ $DEBUG = 0 ]; then
+ /usr/local/Brother/cupswrapper/brcupsconfig3 $PRINTER $PPD 0 "$options" >> /dev/null
+ else
+ /usr/local/Brother/cupswrapper/brcupsconfig3 $PRINTER $PPD $LOGCLEVEL "$options" >>$LOGFILE
+ fi
+fi
+
+
+if [ $DEBUG -le 2 ]; then
+ cat $INPUT_TEMP_PS | /usr/local/Brother/lpd/filter$PRINTER
+fi
+
+if [ $DEBUG -ge 2 ]; then
+ if [ $LOGFILE != "/dev/null" ]; then
+ echo "" >>$LOGFILE
+ echo " ------PostScript Data-------" >>$LOGFILE
+ cat $INPUT_TEMP_PS >>$LOGFILE
+ fi
+fi
+rm -f $INPUT_TEMP_PS
+
+exit $errorcode
+
+
diff --git a/cupswrapper-systemd.patch b/cupswrapper-systemd.patch
new file mode 100644
index 000000000000..1d801938b31a
--- /dev/null
+++ b/cupswrapper-systemd.patch
@@ -0,0 +1,57 @@
+--- usr/local/Brother/cupswrapper/cupswrapperDCP7030-2.0.2 2013-09-04 11:39:39.000000000 +0200
+--- usr/local/Brother/cupswrapper/cupswrapperDCP7030-2.0.2 2013-09-04 11:34:56.863828506 +0200
+@@ -27,22 +27,14 @@
+ if [ -f /usr/share/ppd/DCP7030.ppd ];then
+ rm -f /usr/share/ppd/DCP7030.ppd
+ fi
+- if [ -e /etc/init.d/cups ]; then
+- /etc/init.d/cups restart
+- fi
+- if [ -e /etc/init.d/cupsys ]; then
+- /etc/init.d/cupsys restart
+- fi
++ # restart
++ systemctl restart cupsd
+ exit 0
+ fi
+ if [ "$1" = "-r" ]; then
+ lpadmin -x DCP7030
+- if [ -e /etc/init.d/cups ]; then
+- /etc/init.d/cups restart
+- fi
+- if [ -e /etc/init.d/cupsys ]; then
+- /etc/init.d/cupsys restart
+- fi
++ # restart
++ systemctl restart cupsd
+ exit 0
+ fi
+ if [ "$1" = "help" ] || [ "$1" = "-h" ]; then
+@@ -515,18 +507,8 @@
+
+ chmod a+w /usr/local/Brother/inf/brDCP7030rc
+ chmod a+w /usr/local/Brother/inf
+-if [ -e /etc/init.d/lpd ]; then
+- /etc/init.d/lpd stop
+-fi
+-if [ -e /etc/init.d/lprng ]; then
+- /etc/init.d/lprng stop
+-fi
+- if [ -e /etc/init.d/cups ]; then
+- /etc/init.d/cups restart
+- fi
+- if [ -e /etc/init.d/cupsys ]; then
+- /etc/init.d/cupsys restart
+- fi
++# restart
++systemctl restart cupsd
+ sleep 2s
+ port2=`lpinfo -v | grep -i 'usb://Brother/DCP-7030' | head -1`
+ if [ "$port2" = '' ];then
+@@ -537,4 +519,4 @@
+ port=usb:/dev/usb/lp0
+ fi
+ lpadmin -p DCP7030 -E -v $port -P /usr/share/cups/model/DCP7030.ppd
+- exit 0
++ exit 0
+\ No newline at end of file