summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIngo Sieverdingbeck2015-08-09 15:16:18 +0200
committerIngo Sieverdingbeck2015-08-09 15:16:18 +0200
commitb63250824810a9dabb9d0c7e59f5ac992b62923b (patch)
tree311f1c6bafe4bd87a460983ea233010dfb006442
parent77ed4acc879ca08dd9152a29f17c9688224775e1 (diff)
downloadaur-b63250824810a9dabb9d0c7e59f5ac992b62923b.tar.gz
backup brDCP7065DN{func|rc}
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 37 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1b751126da8..cdc192c0504b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,14 +8,20 @@ pkgbase = brother-dcp7065dn
arch = x86_64
license = custom:brother commercial license
depends = cups
- source = http://www.brother.com/pub/bsc/linux/dlf/dcp7065dnlpr-2.1.0-1.i386.rpm
- source = http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7065DN-2.0.4-2.i386.rpm
+ backup = usr/share/brother/Printer/DCP7065DN/inf/brDCP7065DNfunc
+ backup = usr/share/brother/Printer/DCP7065DN/inf/brDCP7065DNrc
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcp7065dnlpr-2.1.0-1.i386.deb
+ source = http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7065DN-2.0.4-2.i386.deb
source = cupswrapper-license.txt
source = lpr-license.txt
- md5sums = b0582aaca638f158abc0de4048128793
- md5sums = 2c7b96d7f23cc2f0d793e1e4e79fc1ab
+ md5sums = 505edb3ad16df7b00513a6a66ed4b320
+ md5sums = e136add1e00e990796f2b954406da9f7
md5sums = 97ad0cffd216059e9d1d3121899d8646
md5sums = 5e87a3dc0f3e3438c088eda0f3565f0d
+ sha256sums = aeb6b0243b1be22aba99e162eea8abed63b146b8fd55c0dd63c6eada0c148834
+ sha256sums = b7c703cbc7829b850e5a90b30d78e52dfca8bf5b08aa00b280b67f7e07ccb759
+ sha256sums = 2c6aa6a641332e5c87e971ac2a8beae13b059747bdba331bbd515914770d72d9
+ sha256sums = 9d85a8aafdaac8fac80e04234ad2acf5642bbf0b91ee582d2a89519a55f6dd67
pkgname = brother-dcp7065dn
diff --git a/PKGBUILD b/PKGBUILD
index 95b6800c30f8..94fb8de21c31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Libernux <dutchman55@gmx.com>
+# Maintainer: Ingo Sieverdingbeck <aur@sieverdingbeck.com>
pkgname="brother-dcp7065dn"
pkgver="2.0.4"
pkgrel=2
@@ -6,24 +6,45 @@ pkgdesc="LPR and CUPS driver for the Brother DCP7065DN"
arch=('i686' 'x86_64')
url="http://solutions.brother.com/linux/en_us/"
license=('custom:brother commercial license')
+backup=(
+ 'usr/share/brother/Printer/DCP7065DN/inf/brDCP7065DNfunc'
+ 'usr/share/brother/Printer/DCP7065DN/inf/brDCP7065DNrc'
+)
+
depends=('cups')
install="$pkgname.install"
source=(
- "http://www.brother.com/pub/bsc/linux/dlf/dcp7065dnlpr-2.1.0-1.i386.rpm"
- "http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7065DN-$pkgver-$pkgrel.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/dcp7065dnlpr-2.1.0-1.i386.deb"
+ "http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7065DN-$pkgver-$pkgrel.i386.deb"
'cupswrapper-license.txt'
'lpr-license.txt'
)
md5sums=(
- 'b0582aaca638f158abc0de4048128793'
- '2c7b96d7f23cc2f0d793e1e4e79fc1ab'
+ '505edb3ad16df7b00513a6a66ed4b320'
+ 'e136add1e00e990796f2b954406da9f7'
'97ad0cffd216059e9d1d3121899d8646'
'5e87a3dc0f3e3438c088eda0f3565f0d'
)
+
+sha256sums=(
+ 'aeb6b0243b1be22aba99e162eea8abed63b146b8fd55c0dd63c6eada0c148834'
+ 'b7c703cbc7829b850e5a90b30d78e52dfca8bf5b08aa00b280b67f7e07ccb759'
+ '2c6aa6a641332e5c87e971ac2a8beae13b059747bdba331bbd515914770d72d9'
+ '9d85a8aafdaac8fac80e04234ad2acf5642bbf0b91ee582d2a89519a55f6dd67'
+)
+
if test "$CARCH" == x86_64; then
depends+=('lib32-glibc')
fi
prepare() {
+
+ mkdir -p $srcdir/unpack || return 1
+ for i in $srcdir/*.deb; do
+ cd $srcdir/unpack
+ ar -x $i || return 1
+ cd $srcdir
+ bsdtar -pxf $srcdir/unpack/data.tar.gz || return 1
+ done
# do not install in '/usr/local'
if [ -d $srcdir/usr/local/Brother ]; then
install -d $srcdir/usr/share
@@ -59,4 +80,4 @@ package() {
if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
install -m 644 -D cupswrapper-license.txt $pkgdir/usr/share/licenses/${pkgname}/cupswrapper-licence.txt
install -m 644 -D lpr-license.txt $pkgdir/usr/share/licenses/${pkgname}/lpr-licence.txt
-} \ No newline at end of file
+}