summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Westrup2015-06-11 20:34:39 +0200
committerErik Westrup2015-06-11 20:34:39 +0200
commit63ae63583ddc27d4ff7d7807626380c07f53b702 (patch)
treebc3bf8e3ce143f439da635abb6e1cab1b20e8c6f
downloadaur-63ae63583ddc27d4ff7d7807626380c07f53b702.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--brother-dcp7070dw-cups.changelog14
-rw-r--r--brother-dcp7070dw-cups.install19
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6469982823f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-dcp7070dw-cups
+ pkgdesc = Brother DCP-7070DW CUPS drivers.
+ pkgver = 2.0.4_2
+ pkgrel = 3
+ url = http://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=dcp7070dw_eu
+ install = brother-dcp7070dw-cups.install
+ changelog = brother-dcp7070dw-cups.changelog
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom:brother
+ makedepends = rpmextract
+ depends = brother-dcp7070dw-lpr
+ depends = cups
+ optdepends = brscan4: scanner support.
+ noextract = cupswrapperDCP7070DW-2.0.4-2.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7070DW-2.0.4-2.i386.rpm
+ md5sums = a67e6e62d8b768b958c0cebf97064c94
+
+pkgname = brother-dcp7070dw-cups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20401bcb6d36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Erik Westrup <erik.westrup@gmail.com>
+
+pkgname=brother-dcp7070dw-cups
+pkgver=2.0.4_2
+pkgrel=3
+pkgdesc="Brother DCP-7070DW CUPS drivers."
+arch=('i686' 'x86_64')
+url="http://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=dcp7070dw_eu"
+license=('GPL2' 'custom:brother')
+depends=('brother-dcp7070dw-lpr' 'cups')
+makedepends=('rpmextract')
+optdepends=('brscan4: scanner support.')
+install="${pkgname}.install"
+changelog="${pkgname}.changelog"
+source=( "http://www.brother.com/pub/bsc/linux/dlf/cupswrapperDCP7070DW-${pkgver/_/-}.i386.rpm")
+noextract=("cupswrapperDCP7070DW-${pkgver/_/-}.i386.rpm")
+md5sums=('a67e6e62d8b768b958c0cebf97064c94')
+
+prepare() {
+ rpmextract.sh cupswrapperDCP7070DW-${pkgver/_/-}.i386.rpm
+}
+
+build() {
+ sed -i -e 's$/etc/init.d/cups$/etc/rc.d/cupsd$g' -e 's$/etc/init.d$/etc/rc.d$g' "usr/local/Brother/Printer/DCP7070DW/cupswrapper/cupswrapperDCP7070DW-${pkgver%_*}"
+}
+
+package() {
+ cp -r ${srcdir}/usr ${pkgdir}/
+}
diff --git a/brother-dcp7070dw-cups.changelog b/brother-dcp7070dw-cups.changelog
new file mode 100644
index 000000000000..f6a638498785
--- /dev/null
+++ b/brother-dcp7070dw-cups.changelog
@@ -0,0 +1,14 @@
+2015-01-11 Erik Westrup <erik.westrup@gmail.com>
+
+ *2.0.4_2-3
+ Updated URL to point to the product.
+
+2014-04-07 Erik Westrup <erik.westrup@gmail.com>
+
+ *2.0.4_2-2
+ Run setup program with superuser privileges.
+
+2013-08-16 Erik Westrup <erik.westrup@gmail.com>
+
+ *2.0.4_2-1
+ First submission of the package.
diff --git a/brother-dcp7070dw-cups.install b/brother-dcp7070dw-cups.install
new file mode 100644
index 000000000000..8bddd9961d56
--- /dev/null
+++ b/brother-dcp7070dw-cups.install
@@ -0,0 +1,19 @@
+pkgver="2.0.4_2"
+
+post_install() {
+ echo "Running setup program..."
+ sudo /usr/local/Brother/Printer/DCP7070DW/cupswrapper/cupswrapperDCP7070DW-${pkgver%_*}
+ echo "done."
+
+ cat << EOF
+==> Now visit the CUPS configuration page to add your printer @ http://localhost:631/admin
+==>
+==> Install brscan4 for scanner support. Details and script for automating scans: https://github.com/erikw/dotfiles/blob/personal/bin/scan_dcp7070dw.sh
+EOF
+}
+
+pre_remove() {
+ echo "Running setup program to uninstall..."
+ sudo /usr/local/Brother/Printer/DCP7070DW/cupswrapper/cupswrapperDCP7070DW-${pkgver%_*} -e
+ echo "done."
+}