summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordelirein@fastmail.com2018-11-01 22:36:53 +0100
committerdelirein@fastmail.com2018-11-01 22:36:53 +0100
commit5a1caa52c1bdc1e36e7ea591561a88a87cef1afc (patch)
tree03ede4b3396b55331e8c8b0d89e1c671bdaacb3c
downloadaur-brother-dcpj100.tar.gz
Initial driver
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
-rw-r--r--dcpj100.install12
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35f4abcde6a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-dcpj100
+ pkgdesc = CUPS driver for Brother DCP-J100 printer
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = dcpj100.install
+ arch = i686
+ arch = x86_64
+ license = custom:Brother Industries
+ depends = cups
+ depends = tcsh
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj100cupswrapper-3.0.0-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj100lpr-3.0.0-1.i386.rpm
+ md5sums = 33486e8669dd77b0b88711d1b84218fd
+ md5sums = c5add66bcef0f7d95498c44d2c7ba68a
+ depends_x86_64 = lib32-libstdc++5
+ depends_x86_64 = lib32-libcups
+
+pkgname = brother-dcpj100
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebe012341ed3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Tux Tong <huntthetux@gmail.com>
+
+pkgname=brother-dcpj100
+_printername=dcpj100
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="CUPS driver for Brother DCP-J100 printer"
+arch=('i686' 'x86_64')
+license=('custom:Brother Industries')
+depends=('cups' 'tcsh')
+depends_x86_64=('lib32-libstdc++5' 'lib32-libcups')
+url="http://solutions.brother.com/linux/en_us/index.html"
+source=(http://www.brother.com/pub/bsc/linux/dlf/${_printername}cupswrapper-$pkgver-1.i386.rpm \
+ http://www.brother.com/pub/bsc/linux/dlf/${_printername}lpr-$pkgver-1.i386.rpm)
+md5sums=('33486e8669dd77b0b88711d1b84218fd'
+ 'c5add66bcef0f7d95498c44d2c7ba68a')
+install=dcpj100.install
+package() {
+ cp -r "${srcdir}/opt" "${pkgdir}/opt"
+ cp -r "${srcdir}/usr" "${pkgdir}/usr"
+ sed -i 's|/etc/init.d/cups|/etc/rc.d/cupsd|' "${pkgdir}/opt/brother/Printers/dcpj100/cupswrapper/cupswrapperdcpj100"
+}
diff --git a/dcpj100.install b/dcpj100.install
new file mode 100644
index 000000000000..4fb97aaa339c
--- /dev/null
+++ b/dcpj100.install
@@ -0,0 +1,12 @@
+# new package version
+post_install() {
+cat <<-EndOfMessage
+ NOTE 1: Remember to add user to lp group using
+ gpasswd -a USER lp
+ NOTE 2: Remember to logout after adding groups
+ NOTE 3: Remember to execute as root the following executable:
+ /opt/brother/Printers/dcpj100/cupswrapper/cupswrapperdcpj100
+ NOTE 4: x86_64 users should also install 'lib32-libcups' package
+EndOfMessage
+}
+