summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Conzelmann2023-12-19 13:08:01 +0100
committerManuel Conzelmann2023-12-19 13:10:21 +0100
commit6271fc55644018dc9952353cbb693287322e6ec9 (patch)
tree928070d3044a4b1733336f44f2ec88528164d6a3
parent130cefd8a7a403768dc2ac6d3c502902763f0d4b (diff)
downloadaur-6271fc55644018dc9952353cbb693287322e6ec9.tar.gz
added a patch due to user not available in arch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--fix_lp.patch11
3 files changed, 26 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c5a2486ba21..ebba0e900b4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = brother-dcpj1140dw
- pkgdesc = Driver for the Brother DCP-J1140DW
+ pkgdesc = Driver for the Brother DCP-J1140W
pkgver = 3.5.0
pkgrel = 1
url = https://support.brother.com/g/b/producttop.aspx?c=gb&lang=en&prod=dcpj1140dw_eu_as
@@ -7,6 +7,9 @@ pkgbase = brother-dcpj1140dw
arch = x86_64
license = custom:brother
depends = cups
+ source = fix_lp.patch
source = https://download.brother.com/welcome/dlf105352/dcpj1140dwpdrv-3.5.0-1.i386.rpm
+ sha256sums = 0904d8229e550baac634804508a9f4ebee967dc015c366973986476513955fbc
sha256sums = 860d0e1a7203cb692c70dc47e8dbecdbb5541a6ae0dc115baf2943ffe44f7a14
+
pkgname = brother-dcpj1140dw
diff --git a/PKGBUILD b/PKGBUILD
index 123b4d3bb588..df8db9ccf54c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,17 @@ license=('custom:brother')
depends=('cups')
install="$pkgname.install"
arch=('x86_64')
-source=("https://download.brother.com/welcome/dlf105352/dcpj1140dwpdrv-3.5.0-1.i386.rpm")
-sha256sums=('860d0e1a7203cb692c70dc47e8dbecdbb5541a6ae0dc115baf2943ffe44f7a14')
+source=(
+ "fix_lp.patch" \
+"https://download.brother.com/welcome/dlf105352/dcpj1140dwpdrv-3.5.0-1.i386.rpm"
+)
+sha256sums=('0904d8229e550baac634804508a9f4ebee967dc015c366973986476513955fbc'
+'860d0e1a7203cb692c70dc47e8dbecdbb5541a6ae0dc115baf2943ffe44f7a14')
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
package()
{
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..f9484ad597ae
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj1140dw/inf/setupPrintcapij.old 2023-12-19 12:50:07.256638801 +0100
++++ opt/brother/Printers/dcpj1140dw/inf/setupPrintcapij 2023-12-19 12:53:25.375201058 +0100
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+