summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Conzelmann2023-12-19 12:29:05 +0100
committerManuel Conzelmann2023-12-19 12:33:06 +0100
commit98815c9b55652fc7fe94bc122956053fd3b03d93 (patch)
treeeaf75a0f5e620ffe2a20e4b997e6d743e6651096
downloadaur-98815c9b55652fc7fe94bc122956053fd3b03d93.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
-rw-r--r--brother-dcpj1140dw.install28
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c5a2486ba21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = brother-dcpj1140dw
+ pkgdesc = Driver for the Brother DCP-J1140DW
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://support.brother.com/g/b/producttop.aspx?c=gb&lang=en&prod=dcpj1140dw_eu_as
+ install = brother-dcpj1140dw.install
+ arch = x86_64
+ license = custom:brother
+ depends = cups
+ source = https://download.brother.com/welcome/dlf105352/dcpj1140dwpdrv-3.5.0-1.i386.rpm
+ sha256sums = 860d0e1a7203cb692c70dc47e8dbecdbb5541a6ae0dc115baf2943ffe44f7a14
+pkgname = brother-dcpj1140dw
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..123b4d3bb588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Gleb Sinyavskiy <zhulik.gleb@gmail.com> (forked and modified PKGBUILD from brother-dcpj1200w)
+# Maintainer: Manuel Conzelmann
+
+pkgname=brother-dcpj1140dw
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-J1140W"
+url="https://support.brother.com/g/b/producttop.aspx?c=gb&lang=en&prod=dcpj1140dw_eu_as"
+license=('custom:brother')
+depends=('cups')
+install="$pkgname.install"
+arch=('x86_64')
+source=("https://download.brother.com/welcome/dlf105352/dcpj1140dwpdrv-3.5.0-1.i386.rpm")
+sha256sums=('860d0e1a7203cb692c70dc47e8dbecdbb5541a6ae0dc115baf2943ffe44f7a14')
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -Dm755 "$srcdir"/opt/brother/Printers/dcpj1140dw/lpd/$arch/brprintconf_dcpj1140dw "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+ mv "$srcdir"/opt/brother/Printers/dcpj1140dw/lpd/$arch/* "$srcdir"/opt/brother/Printers/dcpj1140dw/lpd
+ rmdir "$srcdir"/opt/brother/Printers/dcpj1140dw/lpd/$arch
+}
diff --git a/brother-dcpj1140dw.install b/brother-dcpj1140dw.install
new file mode 100644
index 000000000000..31ee7b6dce7f
--- /dev/null
+++ b/brother-dcpj1140dw.install
@@ -0,0 +1,28 @@
+post_install() {
+ mkdir -p $pkgdir/var/spool/lpd
+
+ # lpr
+ /opt/brother/Printers/dcpj1200w/inf/setupPrintcapij dcpj1140dw -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj1200w/cupswrapper/cupswrapperdcpj1140dw
+
+ systemctl restart cups.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj1200w/inf/setupPrintcapij dcpj1140dw -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj1200w/cupswrapper/cupswrapperdcpj1140dw -e
+}
+
+op=$1
+shift
+
+$op "$@"