summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoribilux2017-11-12 17:52:56 +0100
committeribilux2017-11-12 17:52:56 +0100
commitfc6263e346797a47c42ef0d8b2d4083855b21cd2 (patch)
tree190507929d1b68af70217262d7c3a1d87af35ed4
downloadaur-fc6263e346797a47c42ef0d8b2d4083855b21cd2.tar.gz
initializing
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
-rw-r--r--brother-dcpj152w.install27
-rw-r--r--fix_lp.patch11
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ca5b62e3d38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-dcpj152w
+ pkgdesc = Driver for the Brother DCP-j152w wifi multifuncional printer
+ pkgver = 3.0.0
+ pkgrel = 3
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpj152w.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj152wlpr-3.0.0-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj152wcupswrapper-3.0.0-1.i386.rpm
+ md5sums = 28d30b4720452dcdc2184dc0d699fcd8
+ md5sums = 14f43bae6694b89fcc9a61cc475a2799
+ md5sums = 97461a91d22c64656d032c14807529b0
+
+pkgname = brother-dcpj152w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a95746fc95eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Alessio Bianchi <venator85@gmail.com>
+# Contributor: Jacek Roszkowski <j.roszk@gmail.com>
+# Contributor: Javier Cordero <jneight@gmail.com>
+# Contributor: Vieux Grognon <vieux@grognon.net>
+# Maintainer: Vieux Grognon <vieux@grognon.net>
+
+pkgname=brother-dcpj152w
+pkgver=3.0.0
+pkgrel=3
+pkgdesc="Driver for the Brother DCP-j152w wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpj152w.install"
+arch=('i686' 'x86_64')
+
+md5sums=('28d30b4720452dcdc2184dc0d699fcd8'
+ '14f43bae6694b89fcc9a61cc475a2799'
+ '97461a91d22c64656d032c14807529b0')
+
+source=(
+ "./fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj152wlpr-3.0.0-1.i386.rpm" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj152wcupswrapper-3.0.0-1.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /opt/brother/Printers/dcpj152w/cupswrapper/cupswrapperdcpj152w
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj152w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
diff --git a/brother-dcpj152w.install b/brother-dcpj152w.install
new file mode 100644
index 000000000000..11d89d7f82c4
--- /dev/null
+++ b/brother-dcpj152w.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj152w/inf/setupPrintcapij dcpj152w -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj152w/cupswrapper/cupswrapperdcpj152w
+
+ systemctl restart org.cups.cupsd.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj152w/inf/setupPrintcapij dcpj152w -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj152w/cupswrapper/cupswrapperdcpj152w -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..93e1fee200f6
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj152w/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpj152w/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+