summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dietrich2016-03-22 20:54:55 +0100
committerDaniel Dietrich2016-03-22 20:54:55 +0100
commite31be74a14d281f2866a9f7c50b7c83454e6355a (patch)
treea6aec747dc28e120fe72d453c8194942a4c833a1
downloadaur-e31be74a14d281f2866a9f7c50b7c83454e6355a.tar.gz
initial release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--brother-dcpj562dw.install27
-rw-r--r--fix_lp.patch11
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..110349066c46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 19:52:17 UTC 2016
+pkgbase = brother-dcpj562dw
+ pkgdesc = Driver for the Brother DCP-J562DW wifi multifuncional printer
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpj562dw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://download.brother.com/welcome/dlf102101/dcpj562dwlpr-1.0.0-0.i386.rpm
+ source = http://download.brother.com/welcome/dlf102102/dcpj562dwcupswrapper-1.0.0-0.i386.rpm
+ md5sums = a1249f09228e540a1404497dbd622720
+ md5sums = 28aaf6a403c9cd2d9496243a978e7a0c
+ md5sums = 006d9ba0e9906f4cf906b1c58ebe8a46
+
+pkgname = brother-dcpj562dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4432a82a6daa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Dietrich <shaddow2k@@gmail..com>
+# Based on the DCP-J552DW PKGBUILD -> Marius Rejdak <mariuswol at gmail dot com>
+pkgname=brother-dcpj562dw
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-J562DW wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install='brother-dcpj562dw.install'
+arch=('i686' 'x86_64')
+
+md5sums=('a1249f09228e540a1404497dbd622720'
+ '28aaf6a403c9cd2d9496243a978e7a0c'
+ '006d9ba0e9906f4cf906b1c58ebe8a46')
+
+source=(
+ "fix_lp.patch" \
+ "http://download.brother.com/welcome/dlf102101/dcpj562dwlpr-$pkgver-0.i386.rpm" \
+ "http://download.brother.com/welcome/dlf102102/dcpj562dwcupswrapper-$pkgver-0.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package()
+{
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj562dw "$pkgdir"/usr/bin/
+ cp -R "$srcdir"/opt "$pkgdir"/opt
+}
diff --git a/brother-dcpj562dw.install b/brother-dcpj562dw.install
new file mode 100644
index 000000000000..c8118f2785a8
--- /dev/null
+++ b/brother-dcpj562dw.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj562dw/inf/setupPrintcapij dcpj562dw -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj562dw/cupswrapper/cupswrapperdcpj562dw
+
+ systemctl restart org.cups.cupsd
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj562dw/inf/setupPrintcapij dcpj562dw -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj562dw/cupswrapper/cupswrapperdcpj562dw -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..ec25c62dde26
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj562dw/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpj562dw/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+