summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariusz Michalak2015-06-12 13:37:27 +0200
committerMariusz Michalak2015-06-12 13:37:27 +0200
commitc5e708433e6e087ef6527968e2f3262f75b92a58 (patch)
treea109c2ffa322cc8e1da5f66ff82bd913d206aaf9
downloadaur-brother-dcpj725dw.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--brother-dcpj725dw.install27
-rw-r--r--fix_lp.patch11
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38e3d3d2748b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-dcpj725dw
+ pkgdesc = Driver for the Brother DCP-J725DW wifi multifuncional printer
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpj725dw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj725dwlpr-3.0.0-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj725dwcupswrapper-3.0.0-1.i386.rpm
+ md5sums = ff7c5a545e7064fa033d385544c7912f
+ md5sums = 76ad1e0f9ca7f68660bd0964aeb4cc90
+ md5sums = 7c81204a9e078f86cb292ad556e8c76a
+
+pkgname = brother-dcpj725dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0121a356ff2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=brother-dcpj725dw
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-J725DW wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpj725dw.install"
+arch=('i686' 'x86_64')
+
+md5sums=('ff7c5a545e7064fa033d385544c7912f'
+ '76ad1e0f9ca7f68660bd0964aeb4cc90'
+ '7c81204a9e078f86cb292ad556e8c76a')
+
+source=(
+ "fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj725dwlpr-$pkgver-1.i386.rpm" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj725dwcupswrapper-$pkgver-1.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj725dw "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
diff --git a/brother-dcpj725dw.install b/brother-dcpj725dw.install
new file mode 100644
index 000000000000..5eba9312835e
--- /dev/null
+++ b/brother-dcpj725dw.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj725dw/inf/setupPrintcapij dcpj725dw -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj725dw/cupswrapper/cupswrapperdcpj725dw
+
+ systemctl restart cups
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj725dw/inf/setupPrintcapij dcpj725dw -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj725dw/cupswrapper/cupswrapperdcpj725dw -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..003923aa3a33
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj725dw/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpj725dw/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+