summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorray454222016-09-29 05:59:05 +0900
committerray454222016-09-29 05:59:05 +0900
commit4c6993bfc61271445b9e6a0d7037f49accd01a89 (patch)
tree9976bb99711e9a756831f6a02cbd66afa0e10357
downloadaur-4c6993bfc61271445b9e6a0d7037f49accd01a89.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
-rw-r--r--brother-dcpj963n.install26
-rw-r--r--fix_lp.patch11
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4b5ba652a1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# 水 9月 28 20:58:19 UTC 2016
+pkgbase = brother-dcpj963n
+ pkgdesc = Driver for the Brother DCP-J963N wifi multifuncional printer
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpj963n.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://download.brother.com/welcome/dlf102170/dcpj963nlpr-1.0.0-0.i386.rpm
+ source = http://download.brother.com/welcome/dlf102171/dcpj963ncupswrapper-1.0.0-0.i386.rpm
+ md5sums = d1a756081b85dd136d44a9a4dae7f052
+ md5sums = 6f9544ccedc82735bd5c325f052cbf2a
+ md5sums = 8bc2ef415bd5522de8557d4f7d1d2d37
+
+pkgname = brother-dcpj963n
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9cbf86991ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=brother-dcpj963n
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-J963N wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpj963n.install"
+arch=('i686' 'x86_64')
+
+md5sums=('d1a756081b85dd136d44a9a4dae7f052'
+ '6f9544ccedc82735bd5c325f052cbf2a'
+ '8bc2ef415bd5522de8557d4f7d1d2d37')
+
+source=(
+ "fix_lp.patch" \
+ "http://download.brother.com/welcome/dlf102170/dcpj963nlpr-$pkgver-0.i386.rpm" \
+ "http://download.brother.com/welcome/dlf102171/dcpj963ncupswrapper-$pkgver-0.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj963n "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
diff --git a/brother-dcpj963n.install b/brother-dcpj963n.install
new file mode 100644
index 000000000000..edd7910484d4
--- /dev/null
+++ b/brother-dcpj963n.install
@@ -0,0 +1,26 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj963n/inf/setupPrintcapij dcpj963n -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj963n/cupswrapper/cupswrapperdcpj963n
+
+ systemctl restart org.cups.cupsd.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj963n/inf/setupPrintcapij dcpj963n -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj963n/cupswrapper/cupswrapperdcpj963n -e
+}
+
+op=$1
+shift
+
+$op "$@"
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..6847f7810357
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj963n/inf/setupPrintcapij.old 2015-04-20 15:57:02.000000000 +0900
++++ opt/brother/Printers/dcpj963n/inf/setupPrintcapij 2016-09-29 05:14:14.442771724 +0900
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir -p $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+