summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTasnad Kernetzky2016-05-27 18:07:03 +0200
committerTasnad Kernetzky2016-05-27 18:07:03 +0200
commitb467644d639ce6dd5e14b3b3d98cee0b87e9f679 (patch)
tree1e046305870643ebe053f9477f355bde17933cec
downloadaur-b467644d639ce6dd5e14b3b3d98cee0b87e9f679.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--99-brprint.rules2
-rw-r--r--PKGBUILD54
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..039ede338d5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = brother-dcpl2520dw
+ pkgdesc = Brother DCP-L2520DW lpr driver and CUPS wrapper.
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=dcpl2520dw_us_eu&os=127&dlid=dlf101757_000&flang=4&type3=558
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom:brother
+ makedepends = rpmextract
+ depends = cups
+ depends = lib32-glibc
+ optdepends = brscan4: scanner support.
+ noextract = dcpl2520dwlpr-3.2.0-1.i386.rpm
+ noextract = dcpl2520dwcupswrapper-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101757/dcpl2520dwlpr-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101758/dcpl2520dwcupswrapper-3.2.0-1.i386.rpm
+ source = 99-brprint.rules
+ md5sums = de61fcda5985944d6dd1e5735cf7897b
+ md5sums = 4beb9def6c55f7c97d6e654c77eaf4a8
+ md5sums = d6535a47019acd179f8317beecf4fcd4
+
+pkgname = brother-dcpl2520dw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5972287ed28a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!99-brprint.rules
+!.gitignore
diff --git a/99-brprint.rules b/99-brprint.rules
new file mode 100644
index 000000000000..a1590891c901
--- /dev/null
+++ b/99-brprint.rules
@@ -0,0 +1,2 @@
+# Needed to get CUPS working with the usblp module.
+ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="0322", MODE:="0660", GROUP:="lp"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..504eca49ed3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Tasnad Kernetzky <tasnadk at gmail dot com>
+
+pkgname=brother-dcpl2520dw
+pkgver=3.2.0_1
+pkgrel=1
+pkgdesc="Brother DCP-L2520DW lpr driver and CUPS wrapper."
+arch=('i686' 'x86_64')
+url="http://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=dcpl2520dw_us_eu&os=127&dlid=dlf101757_000&flang=4&type3=558"
+license=('GPL2' 'custom:brother')
+depends=('cups')
+makedepends=('rpmextract')
+optdepends=('brscan4: scanner support.')
+source=(
+ "http://download.brother.com/welcome/dlf101757/dcpl2520dwlpr-${pkgver/_/-}.i386.rpm"
+ "http://download.brother.com/welcome/dlf101758/dcpl2520dwcupswrapper-${pkgver/_/-}.i386.rpm"
+ '99-brprint.rules'
+)
+noextract=(
+ "dcpl2520dwlpr-${pkgver/_/-}.i386.rpm"
+ "dcpl2520dwcupswrapper-${pkgver/_/-}.i386.rpm"
+)
+md5sums=(
+ 'de61fcda5985944d6dd1e5735cf7897b'
+ '4beb9def6c55f7c97d6e654c77eaf4a8'
+ 'd6535a47019acd179f8317beecf4fcd4'
+)
+
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+
+prepare() {
+ rpmextract.sh dcpl2520dwlpr-${pkgver/_/-}.i386.rpm
+
+ rpmextract.sh dcpl2520dwcupswrapper-${pkgver/_/-}.i386.rpm
+ sed -i -e '47,53c my $basedir = "/opt/brother/Printers/DCPL2520DW";' \
+ ${srcdir}/opt/brother/Printers/DCPL2520DW/cupswrapper/brother_lpdwrapper_DCPL2520DW
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/cups/model/Brother
+ mkdir -p ${pkgdir}/usr/lib/cups/filter
+ cp ${srcdir}/opt/brother/Printers/DCPL2520DW/cupswrapper/brother-DCPL2520DW-cups-en.ppd ${pkgdir}/usr/share/cups/model/Brother
+ cp ${srcdir}/opt/brother/Printers/DCPL2520DW/cupswrapper/brother_lpdwrapper_DCPL2520DW ${pkgdir}/usr/lib/cups/filter
+
+ mkdir -p ${pkgdir}/opt/brother/Printers/DCPL2520DW
+ cp -r ${srcdir}/opt/brother/Printers/DCPL2520DW/inf ${pkgdir}/opt/brother/Printers/DCPL2520DW/
+ cp -r ${srcdir}/opt/brother/Printers/DCPL2520DW/lpd ${pkgdir}/opt/brother/Printers/DCPL2520DW/
+ cp -r ${srcdir}/var ${pkgdir}/
+ cp -r ${srcdir}/etc ${pkgdir}/
+
+ install -m 644 -D 99-brprint.rules $pkgdir/etc/udev/rules.d/99-brprint.rules
+}
+