summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqwertzdenek2020-09-04 12:33:46 +0200
committerqwertzdenek2020-09-04 12:33:46 +0200
commit6c377bf6c82a299e0d1fe7c773daa6c6c42e2c7c (patch)
treea48a4fa7fa1f22f382c6d01391b6da8b6f28e4c5
downloadaur-6c377bf6c82a299e0d1fe7c773daa6c6c42e2c7c.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--brother-dcpt310.install9
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1c8ebd4a065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-dcpt310
+ pkgdesc = Driver for the Brother DCP-T310 multifuncional printer
+ pkgver = 1.0.1
+ pkgrel = 0
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpt310.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ depends = a2ps
+ depends = cups
+ depends = lib32-glibc
+ optdepends = sane: scanning support
+ optdepends = brscan4: making dcpt310 available to sane
+ optdepends = brscan-skey: scankey support if connected via usb
+ source = https://download.brother.com/welcome/dlf103619/dcpt310pdrv-1.0.1-0.i386.rpm
+ sha256sums = 4a429a26c4c578580a78a6dcb56570e3e7aee66505ed40804ef18ace6d7853ed
+
+pkgname = brother-dcpt310
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..465b65f8147f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Zdenek Janecek <ycdmdj@gmail.com>
+
+pkgname=brother-dcpt310
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Driver for the Brother DCP-T310 multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+install="brother-dcpt310.install"
+arch=('i686' 'x86_64')
+optdepends=('sane: scanning support'
+ 'brscan4: making dcpt310 available to sane'
+ 'brscan-skey: scankey support if connected via usb')
+
+if [[ "$CARCH" == "x86_64" ]] ; then
+ depends=('a2ps' 'cups' 'lib32-glibc')
+elif [[ "$CARCH" == "i686" ]] ; then
+ depends=('a2ps' 'cups')
+fi
+
+source=(
+ "https://download.brother.com/welcome/dlf103619/dcpt310pdrv-$pkgver-0.i386.rpm"
+)
+sha256sums=(
+ '4a429a26c4c578580a78a6dcb56570e3e7aee66505ed40804ef18ace6d7853ed'
+)
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpt310 "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
+
diff --git a/brother-dcpt310.install b/brother-dcpt310.install
new file mode 100644
index 000000000000..ff746afd0c83
--- /dev/null
+++ b/brother-dcpt310.install
@@ -0,0 +1,9 @@
+post_install() {
+ /opt/brother/Printers/dcpt310/cupswrapper/cupswrapperdcpt310
+ systemctl restart org.cups.cupsd.service
+}
+
+pre_remove() {
+ /opt/brother/Printers/dcpt310/cupswrapper/cupswrapperdcpt310 -e
+}
+