summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Fernando Mesa Giraldo2016-10-22 08:56:28 -0500
committerSamuel Fernando Mesa Giraldo2016-10-22 08:56:28 -0500
commit188c7e83847f66d8f3ed20f694d39ff9360ac3d2 (patch)
tree125b969fd2b2faf8dc3f4c857b91fa37822ae0a2
downloadaur-188c7e83847f66d8f3ed20f694d39ff9360ac3d2.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--brother-dcpt500w.install27
-rw-r--r--fix_lp.patch11
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0733639a3de5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-dcpt500w
+ pkgdesc = Driver for the Brother DCP-T500W wifi multifuncional printer
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpt500w.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://download.brother.com/welcome/dlf101954/dcpt500wlpr-3.0.2-0.i386.rpm
+ source = http://download.brother.com/welcome/dlf101955/dcpt500wcupswrapper-3.0.2-0.i386.rpm
+ md5sums = 6d76dd9b018d417e75a8eabb51dc3080
+ md5sums = d7cfc19a591c00378219059c6cc901df
+ md5sums = 0741ac139077747bd4966c86d62d1f26
+
+pkgname = brother-dcpt500w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2569a4f0f4f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Samuel Fernando Mesa Giraldo <samuelmesa@linuxmail.org>
+
+pkgname=brother-dcpt500w
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-T500W wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpt500w.install"
+arch=('i686' 'x86_64')
+
+md5sums=('6d76dd9b018d417e75a8eabb51dc3080'
+ 'd7cfc19a591c00378219059c6cc901df'
+ '0741ac139077747bd4966c86d62d1f26')
+
+source=(
+ "fix_lp.patch" \
+ "http://download.brother.com/welcome/dlf101954/dcpt500wlpr-$pkgver-0.i386.rpm" \
+ "http://download.brother.com/welcome/dlf101955/dcpt500wcupswrapper-$pkgver-0.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /opt/brother/Printers/dcpt500w/cupswrapper/cupswrapperdcpt500w
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpt500w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
diff --git a/brother-dcpt500w.install b/brother-dcpt500w.install
new file mode 100644
index 000000000000..c000ca5840a0
--- /dev/null
+++ b/brother-dcpt500w.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpt500w/inf/setupPrintcapij dcpt500w -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpt500w/cupswrapper/cupswrapperdcpt500w
+
+ systemctl restart org.cups.cupsd.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpt500w/inf/setupPrintcapij dcpt500w -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpt500w/cupswrapper/cupswrapperdcpt500w -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..8663863add98
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpt500w/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpt500w/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+