summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErick Pires2016-11-26 17:45:43 -0200
committerErick Pires2016-11-26 17:45:43 -0200
commite6888d903c45abc55f7533fdd30ae7ec21c47aef (patch)
treed0a5cf66acc67162cf29f4a2f0f91627e4d86bd5
downloadaur-brother-hl1200.tar.gz
Driver for the Brother HL-1200 series laser printer. This package was based on the brother-hl1210w package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a0833ccba1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brother-hl1200
+ pkgdesc = Brother HL-1200 CUPS driver (based on the HL-1210W driver package). After installing this, connect the printer and install it from CUPS web interface (default localhost:631)
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://support.brother.com/g/b/downloadlist.aspx?c=us_ot&lang=en&prod=hl1202_us&os=127
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = lib32-glibc
+ depends = cups>=2.1.2
+ source = http://download.brother.com/welcome/dlf101869/hl1200lpr-3.0.1-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101870/hl1200cupswrapper-3.0.1-1.i386.rpm
+ md5sums = de895b93a9cdb562c5b8be633ae6c0ad
+ md5sums = 79a5b0119985bc89c6dc16dfee6e9c1b
+
+pkgname = brother-hl1200
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3fb9f70978c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: erickpires <pires at erickpires dot com>
+pkgname="brother-hl1200"
+pkgver="3.0.1"
+pkgrel="1"
+pkgdesc="Brother HL-1200 CUPS driver (based on the HL-1210W driver package). After installing this, connect the printer and install it from CUPS web interface (default localhost:631)"
+url="http://support.brother.com/g/b/downloadlist.aspx?c=us_ot&lang=en&prod=hl1202_us&os=127"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('lib32-glibc' 'cups>=2.1.2' )
+md5sums=('de895b93a9cdb562c5b8be633ae6c0ad'
+ '79a5b0119985bc89c6dc16dfee6e9c1b')
+source=(
+ http://download.brother.com/welcome/dlf101869/hl1200lpr-3.0.1-1.i386.rpm \
+ http://download.brother.com/welcome/dlf101870/hl1200cupswrapper-3.0.1-1.i386.rpm
+)
+
+
+
+
+package() {
+ mkdir -p "$pkgdir/usr/share/cups/model/"
+ mkdir -p "$pkgdir/usr/lib/cups/filter/"
+
+ cp "$srcdir/opt/brother/Printers/HL1200/cupswrapper/brother-HL1200-cups-en.ppd" "$pkgdir/usr/share/cups/model/brother-HL1200-cups-en.ppd"
+ cp "$srcdir/opt/brother/Printers/HL1200/cupswrapper/brother_lpdwrapper_HL1200" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_HL1200"
+ cp -r "$srcdir/opt/" "$pkgdir/opt/"
+
+}
+