summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwmax6412016-01-03 13:36:20 +1100
committerwmax6412016-01-03 13:36:20 +1100
commitca2a6abb61255a4a154cab8c82b8f00ac38eef35 (patch)
treea661f5a01d8c29eb65c2d22f8869123dc1b4df03
downloadaur-ca2a6abb61255a4a154cab8c82b8f00ac38eef35.tar.gz
inint
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0188dbdcc57f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 3 02:33:15 UTC 2016
+pkgbase = brother-hl1210w
+ pkgdesc = Brother HL-1210W CUPS driver. After installing this, install printer from CUPS web interface (default localhost:631)
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://support.brother.com/g/b/downloadtop.aspx?c=au&lang=en&prod=hl1210w_eu_as
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = lib32-glibc
+ depends = cups>=2.1.2
+ source = http://download.brother.com/welcome/dlf101549/hl1210wlpr-3.0.1-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101548/hl1210wcupswrapper-3.0.1-1.i386.rpm
+ md5sums = 76db4e113a1186f86410146b2ea39166
+ md5sums = 0d7c2ba3a1a30b5babd855efac48b1fb
+
+pkgname = brother-hl1210w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddb45bbf4201
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: wmax641 <spam at wmax641 dot website>
+pkgname="brother-hl1210w"
+pkgver="3.0.1"
+pkgrel="1"
+pkgdesc="Brother HL-1210W CUPS driver. After installing this, install printer from CUPS web interface (default localhost:631)"
+url="http://support.brother.com/g/b/downloadtop.aspx?c=au&lang=en&prod=hl1210w_eu_as"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('lib32-glibc' 'cups>=2.1.2' )
+md5sums=('76db4e113a1186f86410146b2ea39166'
+ '0d7c2ba3a1a30b5babd855efac48b1fb')
+source=(
+ http://download.brother.com/welcome/dlf101549/hl1210wlpr-3.0.1-1.i386.rpm \
+ http://download.brother.com/welcome/dlf101548/hl1210wcupswrapper-3.0.1-1.i386.rpm
+)
+
+
+package() {
+ mkdir -p "$pkgdir/usr/share/cups/model/"
+ mkdir -p "$pkgdir/usr/lib/cups/filter/"
+
+ cp "$srcdir/opt/brother/Printers/HL1210W/cupswrapper/brother-HL1210W-cups-en.ppd" "$pkgdir/usr/share/cups/model/brother-HL1210W-cups-en.ppd"
+ cp "$srcdir/opt/brother/Printers/HL1210W/cupswrapper/brother_lpdwrapper_HL1210W" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_HL1210W"
+ cp -r "$srcdir/opt/" "$pkgdir/opt/"
+
+}
+