summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio de la Cruz2015-09-14 11:50:57 -0700
committerSergio de la Cruz2015-09-14 11:50:57 -0700
commit8a79353bed2f7e9ffbb31be1da19e4448b12b8b0 (patch)
tree81e71d4b563401380b5ab1f168a9213dea2606cd
downloadaur-8a79353bed2f7e9ffbb31be1da19e4448b12b8b0.tar.gz
Initial import. Based on the AUR brother-hl2270dw package
-rw-r--r--.SRCINFO19
-rw-r--r--HL2280DW.ppd.patch8
-rw-r--r--PKGBUILD73
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8671624faa7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = brother-hl2280dw
+ pkgdesc = Brother HL-2280DW CUPS Driver
+ pkgver = 2.0.4_2
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = a2ps
+ depends = cups
+ source = http://www.brother.com/pub/bsc/linux/dlf/hl2280dwlpr-2.1.0-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/cupswrapperHL2280DW-2.0.4-2.i386.rpm
+ source = HL2280DW.ppd.patch
+ md5sums = efa44d4acc0e62633e2d742e445b811a
+ md5sums = b687b69f530275de86d71cbc46352413
+ md5sums = de9cee3fed4afb1ee7f5516b5bac9f25
+
+pkgname = brother-hl2280dw
+
diff --git a/HL2280DW.ppd.patch b/HL2280DW.ppd.patch
new file mode 100644
index 000000000000..b91add0deb51
--- /dev/null
+++ b/HL2280DW.ppd.patch
@@ -0,0 +1,8 @@
+279c279,283
+<
+---
+> *OpenUI *Margins/Page Margins/Offsets: PickOne
+> *DefaultMargins: Custom
+> *Margins Default/Driver Default: ""
+> *Margins Custom/Custom (set with 'alignmargins'): "<</.HWMargins[0 0 0 0] /Margins[0 0]>>setpagedevice"
+> *CloseUI: *Margins
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fab80a503f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Jonathan Doman <jonathan dot doman at gmail dot com>
+# Contributor: Jason St. John <jstjohn .. purdue . edu>
+
+pkgname=brother-hl2280dw
+pkgver=2.0.4_2
+pkgrel=5
+pkgdesc="Brother HL-2280DW CUPS Driver"
+arch=('i686' 'x86_64')
+url='http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html'
+license=('GPL')
+depends=('a2ps' 'cups')
+source=("http://www.brother.com/pub/bsc/linux/dlf/hl2280dwlpr-2.1.0-1.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/cupswrapperHL2280DW-${pkgver//_/-}.i386.rpm"
+ "HL2280DW.ppd.patch")
+md5sums=('efa44d4acc0e62633e2d742e445b811a'
+ 'b687b69f530275de86d71cbc46352413'
+ 'de9cee3fed4afb1ee7f5516b5bac9f25')
+
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glibc')
+fi
+
+package() {
+ _cupswrapperFile="$srcdir/usr/local/Brother/Printer/HL2280DW/cupswrapper/cupswrapperHL2280DW-2.0.4"
+
+ # Ignore everything after the PPD file
+ sed -i -e '/^!ENDOFWFILTER!/ q' "${_cupswrapperFile}"
+ sed -i -e 's#/usr#$srcdir/usr#' "${_cupswrapperFile}"
+
+ sed -i -e 's#/usr/local#/usr/share#' "$srcdir/usr/local/Brother/Printer/HL2280DW/lpd/filterHL2280DW"
+
+ mkdir -p "$srcdir/usr/share/cups/model/"
+
+ # Run the install script to extract the PPD file
+ . "${_cupswrapperFile}"
+
+ # Remove unnecessary files
+ rm "$srcdir/usr/local/Brother/Printer/HL2280DW/inf/setupPrintcap2"
+ rm "${_cupswrapperFile}"
+
+ # Change the PPD description to match other listing for Brother printers in CUPS
+ sed -i -e 's/Brother HL2280DW for CUPS/Brother HL-2280DW/' "$srcdir/usr/share/cups/model/HL2280DW.ppd"
+
+ # Add margin correction (alignmargins output: https://wiki.linuxfoundation.org/en/OpenPrinting/Database/CUPSDocumentation)
+ patch "$srcdir/usr/share/cups/model/HL2280DW.ppd" < "$srcdir/HL2280DW.ppd.patch"
+
+ # Replace references to $srcdir
+ sed -i -e "s#$srcdir/usr#/usr#" "$srcdir/usr/lib/cups/filter/brlpdwrapperHL2280DW"
+ sed -i -e "s#/usr/local#/usr/share#" "$srcdir/usr/lib/cups/filter/brlpdwrapperHL2280DW"
+
+ chmod +x "$srcdir/usr/lib/cups/filter/brlpdwrapperHL2280DW"
+
+ # Change the path for pstops
+ sed -i -e "s#/usr/sbin/pstops#/usr/lib/cups/filter/pstops#" "$srcdir/usr/local/Brother/Printer/HL2280DW/lpd/psconvert2"
+ sed -i -e "s#/usr/bin/pstops#/usr/lib/cups/filter/pstops#" "$srcdir/usr/local/Brother/Printer/HL2280DW/lpd/filterHL2280DW"
+
+ # Change some hardcoded paths in the binaries (source code is available for
+ # one but not the others, so I figure I'll just hack the changes for all)
+ sed -i -e "s#/usr/local/#/usr/share/#g" "$srcdir/usr/local/Brother/Printer/HL2280DW/cupswrapper/brcupsconfig4"
+ sed -i -e "s#/usr/local/#/usr/share/#g" "$srcdir/usr/local/Brother/Printer/HL2280DW/inf/brprintconflsr3"
+ sed -i -e "s#/usr/local/#/usr/share/#g" "$srcdir/usr/local/Brother/Printer/HL2280DW/inf/braddprinter"
+
+ # Copy the src tree into the pkg tree
+ cp -R "$srcdir/usr/" "$pkgdir/"
+ cp -R "$srcdir/var/" "$pkgdir/"
+
+ mv "$pkgdir/usr/local/Brother" "$pkgdir/usr/share/"
+ rmdir "$pkgdir/usr/local"
+
+ chmod a+w "$pkgdir/usr/share/Brother/Printer/HL2280DW/inf/brHL2280DWrc"
+}
+
+# vim:set ts=2 sw=2 et: