summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhhdev2022-08-13 00:20:09 +0300
committerhhdev2022-08-13 00:20:09 +0300
commit5270862d9dfc32cc191866b7963b9e56c5060d36 (patch)
treecb02637c7ef64cf9616059eb761a391fdf3b25a8
downloadaur-brother-hl5250dn-cups-ppd.tar.gz
CUPS driver and PPD for Brother HL5250DN printer
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ec910736762
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = brother-hl5250dn-cups-ppd
+ pkgdesc = CUPS wrapper print driver and PPD file for Brother HL-5250DN
+ pkgver = 2.0.1_2
+ pkgrel = 1
+ url = https://support.brother.com/g/b/producttop.aspx?c=us&lang=en&prod=hl5250dn_all
+ arch = i686
+ arch = x86_64
+ groups = base-devel
+ license = EULA
+ depends = cups
+ optdepends = psutils
+ optdepends = ghostscript
+ optdepends = mupdf
+ source = https://download.brother.com/welcome/dlf005986/cupswrapperHL5250DN-2.0.1-2.i386.deb
+ source = https://download.brother.com/welcome/dlf005987/BR5250_2_GPL.ppd.gz
+ md5sums = c4f27115360e9293346ac3a0ed39fca4
+ md5sums = 8a395079334634f348d1cd7bcee8170b
+
+pkgname = brother-hl5250dn-cups-ppd
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd44ee55be9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Helhet <hhdev@proton.me>
+
+pkgname=brother-hl5250dn-cups-ppd
+pkgver=2.0.1_2
+pkgrel=1
+pkgdesc="CUPS wrapper print driver and PPD file for Brother HL-5250DN"
+arch=("i686" "x86_64")
+url="https://support.brother.com/g/b/producttop.aspx?c=us&lang=en&prod=hl5250dn_all"
+license=("EULA")
+groups=("base-devel")
+source=(
+ 'https://download.brother.com/welcome/dlf005986/cupswrapperHL5250DN-2.0.1-2.i386.deb'
+ 'https://download.brother.com/welcome/dlf005987/BR5250_2_GPL.ppd.gz'
+)
+md5sums=("c4f27115360e9293346ac3a0ed39fca4"
+ "8a395079334634f348d1cd7bcee8170b")
+depends=('cups')
+optdepends=('psutils'
+ 'ghostscript'
+ 'mupdf'
+ )
+
+package() {
+ tar -xf data.tar.gz -C "${pkgdir}"
+ # Add .ppd
+ install -m 644 -D BR5250_2_GPL.ppd "$pkgdir/etc/cups/ppd/BR5250_2_GPL.ppd"
+}
+