summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNGlen2018-08-20 10:21:18 -0400
committerNGlen2018-08-20 10:21:18 -0400
commitd34775fcb2998fd510a27d9283c75d6335a7237d (patch)
treee7f7befdb0c873d603c70bd575632c870820e061
downloadaur-d34775fcb2998fd510a27d9283c75d6335a7237d.tar.gz
First Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD52
-rw-r--r--brother_lpdwrapper_HLL2305.patch23
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec420dc216f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-hll2305w
+ pkgdesc = LPR and CUPS driver for HLL2305 model.
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://support.brother.com/g/s/id/linux/en
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ depends = ghostscript
+ depends = lib32-glibc
+ source = http://download.brother.com/welcome/dlf101902/hll2305lpr-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101903/hll2305cupswrapper-3.2.0-1.i386.rpm
+ source = brother_lpdwrapper_HLL2305.patch
+ md5sums = 9a62315bab0d4e3e92637cfd8432ba73
+ md5sums = 1f86aab2fc7c243723d40ff9c40ec081
+ md5sums = dc776a2b7cc4be618624a1bba896ccca
+
+pkgname = brother-hll2305w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c878a87e002e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Nathaniel <njag2202@gmail.com>
+
+pkgname=brother-hll2305w
+pkgver=3.2.0_1
+pkgrel=1
+_brotherpkgver=${pkgver:0:$((${#pkgver}-2))}
+_brotherrelease=${pkgver:$((${#pkgver}-1))}
+_brotherdrivername=HLL2305
+pkgdesc="LPR and CUPS driver for HLL2305 model."
+arch=('i686' 'x86_64')
+url='http://support.brother.com/g/s/id/linux/en'
+license=('GPL')
+depends=('cups' 'ghostscript')
+
+source=("http://download.brother.com/welcome/dlf101902/hll2305lpr-${_brotherpkgver}-${_brotherrelease}.i386.rpm"
+ "http://download.brother.com/welcome/dlf101903/hll2305cupswrapper-${_brotherpkgver}-${_brotherrelease}.i386.rpm"
+ "brother_lpdwrapper_${_brotherdrivername}.patch")
+
+md5sums=('9a62315bab0d4e3e92637cfd8432ba73'
+ '1f86aab2fc7c243723d40ff9c40ec081'
+ 'dc776a2b7cc4be618624a1bba896ccca')
+
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glibc')
+fi
+
+prepare() {
+
+patch "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}" < "$srcdir/brother_lpdwrapper_${_brotherdrivername}.patch"
+
+}
+
+package() {
+
+cp -a "$srcdir/var" "$pkgdir"
+
+install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother-${_brotherdrivername}-cups-en.ppd" "$pkgdir/usr/share/cups/model/brother-${_brotherdrivername}-cups-en.ppd"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/brother_lpdwrapper_${_brotherdrivername}" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${_brotherdrivername}"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/cupswrapper/paperconfigml1" "$pkgdir/usr/share/Brother/Printer/$_brotherdrivername/cupswrapper/paperconfigml1"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/braddprinter" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/braddprinter"
+install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/br${_brotherdrivername}func" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/br${_brotherdrivername}func"
+install -Dm644 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/br${_brotherdrivername}rc" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/br${_brotherdrivername}rc"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/inf/setupPrintcap" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/inf/setupPrintcap"
+
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/brprintconflsr3" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/brprintconflsr3"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/filter_${_brotherdrivername}" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/filter_${_brotherdrivername}"
+install -Dm755 "$srcdir/opt/brother/Printers/${_brotherdrivername}/lpd/rawtobr3" "$pkgdir/usr/share/Brother/Printer/${_brotherdrivername}/lpd/rawtobr3"
+
+}
diff --git a/brother_lpdwrapper_HLL2305.patch b/brother_lpdwrapper_HLL2305.patch
new file mode 100644
index 000000000000..76eaf0f49f25
--- /dev/null
+++ b/brother_lpdwrapper_HLL2305.patch
@@ -0,0 +1,23 @@
+53,54c53,55
+< $basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
+<
+---
+> #$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
+> my $PRINTER = "HLL2305";
+> my $basedir = "/usr/share/Brother/Printer/$PRINTER";
+80c81
+< my $PRINTER=$basedir;
+---
+> #my $PRINTER=$basedir;
+87,89c88,90
+< $PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+< $PRINTER =~ s/\/cupswrapper//g;
+< $PRINTER =~ s/\///g;
+---
+> #$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+> #$PRINTER =~ s/\/cupswrapper//g;
+> #$PRINTER =~ s/\///g;
+736c737
+< $lpddir = $basedir."/lpd/";
+---
+> $lpddir = $basedir."/lpd";