summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxanx2015-07-12 10:08:24 -0400
committerxanx2015-07-12 10:08:24 -0400
commit120a1091a8048e70ab10c4fca53c84d50993c0b9 (patch)
tree8e93e4264fdb60ea5d59931677c5df35beb684d4
downloadaur-brother-hll2320d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e446e8fa189d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brother-hll2320d
+ pkgdesc = Brother HL-L2320D CUPS driver
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = x86_64
+ arch = i686
+ license = custom:Brother
+ depends = perl
+ depends = bash
+ source = http://download.brother.com/welcome/dlf101906/hll2320dlpr-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101907/hll2320dcupswrapper-3.2.0-1.i386.rpm
+ md5sums = ca753f68807bd1002c2000225512a75b
+ md5sums = 98d6f5fdbb50d6a3a2557a2630c7bc0e
+
+pkgname = brother-hll2320d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd02e9ac61c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Brian Durksen <brian at durksen dot pw>
+pkgname=brother-hll2320d
+pkgver=3.2.0_1
+pkgrel=1
+pkgdesc="Brother HL-L2320D CUPS driver"
+url="http://www.brother.com"
+arch=('x86_64' 'i686')
+depends=('perl' 'bash')
+license=('custom:Brother')
+source=(
+ "http://download.brother.com/welcome/dlf101906/hll2320dlpr-${pkgver//_/-}.i386.rpm"
+ "http://download.brother.com/welcome/dlf101907/hll2320dcupswrapper-${pkgver//_/-}.i386.rpm"
+)
+md5sums=(
+ 'ca753f68807bd1002c2000225512a75b'
+ '98d6f5fdbb50d6a3a2557a2630c7bc0e'
+)
+
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glibc')
+fi
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+
+ mkdir -p "${pkgdir}/usr/lib/cups/filter"
+ echo "#! /opt/brother/Printers/HLL2320D/cupswrapper/brother_lpdwrapper_HLL2320D" > "${srcdir}/filter-shim"
+ install -m 0755 -o root -g root "${srcdir}/filter-shim" "${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_HLL2320D"
+
+ mkdir -p "${pkgdir}/usr/share/ppd/cupsfilters"
+ install -m 0644 -o root -g root "${srcdir}/opt/brother/Printers/HLL2320D/cupswrapper/brother-HLL2320D-cups-en.ppd" "${pkgdir}/usr/share/ppd/cupsfilters"
+} \ No newline at end of file