summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Lassieur2016-01-29 10:22:14 +0100
committerClément Lassieur2016-01-29 10:22:14 +0100
commitefedef2d544b635cb62a7bf05d301b4ebe95eb65 (patch)
tree4c8711ac5fe08f5547794842428e88b7bc5eca34
downloadaur-efedef2d544b635cb62a7bf05d301b4ebe95eb65.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--brother-hll2360d.patch30
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bb9c41588ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 09:21:25 UTC 2016
+pkgbase = brother-hll2360d
+ pkgdesc = Brother HL-L2360D CUPS driver
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ source = brother-hll2360d.patch
+ source = http://download.brother.com/welcome/dlf101915/hll2360dcupswrapper-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101914/hll2360dlpr-3.2.0-1.i386.rpm
+ md5sums = c660e4907fa7594f99305c9862414c03
+ md5sums = 881e966395a2d67ee648046c9547031b
+ md5sums = 2a0e27f233d8cbb5dc8e332230db03e7
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-hll2360d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e7346550312
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Clément Lassieur <clement@lassieur.org>
+pkgname="brother-hll2360d"
+pkgver="3.2.0_1"
+pkgrel="1"
+pkgdesc="Brother HL-L2360D CUPS driver"
+url="http://www.brother.com"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+
+source=(brother-hll2360d.patch
+ http://download.brother.com/welcome/dlf101915/hll2360dcupswrapper-${pkgver//_/-}.i386.rpm
+ http://download.brother.com/welcome/dlf101914/hll2360dlpr-${pkgver//_/-}.i386.rpm)
+md5sums=('c660e4907fa7594f99305c9862414c03'
+ '881e966395a2d67ee648046c9547031b'
+ '2a0e27f233d8cbb5dc8e332230db03e7')
+
+prepare() {
+ patch -p1 < "$srcdir/brother-hll2360d.patch"
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ install -d "$pkgdir/usr/share/cups/model/"
+
+ cp -R "$srcdir/opt/brother" "$pkgdir/usr/share/brother"
+
+ ln -s "/usr/share/brother/Printers/HLL2360D/cupswrapper/brother_lpdwrapper_HLL2360D" "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/HLL2360D/cupswrapper/brother-HLL2360D-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
+}
diff --git a/brother-hll2360d.patch b/brother-hll2360d.patch
new file mode 100644
index 000000000000..79f3bfef9f03
--- /dev/null
+++ b/brother-hll2360d.patch
@@ -0,0 +1,30 @@
+diff --git a/brother_lpdwrapper_HLL2360D b/brother_lpdwrapper_HLL2360D.new
+index 1af93d4..f7d1bfd 100755
+--- a/opt/brother/Printers/HLL2360D/cupswrapper/brother_lpdwrapper_HLL2360D
++++ b/opt/brother/Printers/HLL2360D/cupswrapper/brother_lpdwrapper_HLL2360D
+@@ -43,15 +43,7 @@ if ( $DEBUG > 0 ){
+ $width=-1;
+ $height=-1;
+
+-#my $basedir = Cwd::realpath ($0);
+-my $basedir = `readlink $0`;
+-if ( $basedir eq '' ){
+- $basedir = `realpath $0`;
+-}
+-chomp($basedir);
+-
+-$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
+-
++my $basedir = "/usr/share/brother/Printers/HLL2360D";
+
+ %units = ( pt => \&pt2dot,
+ mm => \&mm2dot,
+@@ -84,7 +76,7 @@ if ( @ARGV >= 6 ){
+ }
+
+
+-$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
++$PRINTER =~ s/^\/usr\/share\/.*\/Printers\///g;
+ $PRINTER =~ s/\/cupswrapper//g;
+ $PRINTER =~ s/\///g;
+