summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKopfKrieg2018-02-13 19:51:11 +0100
committerKopfKrieg2018-02-13 19:51:11 +0100
commit321862bf2859f3814b29c401324a54921a3039ad (patch)
tree097402ba712a18b2db83cd6d8b9ddadf397615b9
downloadaur-321862bf2859f3814b29c401324a54921a3039ad.tar.gz
Initial commit, added printer driver
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c1cee08277c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = brother-hll2375dw
+ pkgdesc = Brother HL-L2375DW CUPS driver
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ depends = perl
+ source = http://download.brother.com/welcome/dlf103533/hll2375dwpdrv-4.0.0-1.i386.rpm
+ sha256sums = ce32797b7f344d2cd7dec958a65a35887ab604a5e47f108de096e8caeb098a85
+
+pkgname = brother-hll2375dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e27d285cd8ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: KopfKrieg <archlinux at absolem dot cc>
+# Contributor: Daniel Wyatt <Daniel.Wyatt at gmail dot com>
+pkgname=brother-hll2375dw
+pkgver=4.0.0
+pkgrel=1
+pkgdesc='Brother HL-L2375DW CUPS driver'
+arch=('i686' 'x86_64')
+url='http://www.brother.com'
+license=('GPL')
+depends=('cups' 'perl')
+source=(http://download.brother.com/welcome/dlf103533/hll2375dwpdrv-$pkgver-1.i386.rpm)
+sha256sums=('ce32797b7f344d2cd7dec958a65a35887ab604a5e47f108de096e8caeb098a85')
+
+package() {
+ # using /usr/share instead of /opt
+ mkdir -p "$pkgdir/usr/share"
+ cp -R "$srcdir/opt/brother" "$pkgdir/usr/share"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/HLL2375DW/cupswrapper/lpdwrapper"
+ sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/HLL2375DW/lpd/lpdfilter"
+
+ # symlink for lpdwrapper so it correctly figures out the printer model from the path
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/HLL2375DW/cupswrapper/lpdwrapper" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_HLL2375DW"
+
+ # symlink for the PPD
+ install -d "$pkgdir/usr/share/cups/model/"
+ ln -s "/usr/share/brother/Printers/HLL2375DW/cupswrapper/brother-HLL2375DW-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
+
+ # a couple architecture-specific symlinks
+ ln -s "/usr/share/brother/Printers/HLL2375DW/lpd/$CARCH/brprintconflsr3" "$pkgdir/usr/share/brother/Printers/HLL2375DW/lpd/"
+ ln -s "/usr/share/brother/Printers/HLL2375DW/lpd/$CARCH/rawtobr3" "$pkgdir/usr/share/brother/Printers/HLL2375DW/lpd/"
+
+ # symlink for inf because it tries to execute it there
+ ln -s "/usr/share/brother/Printers/HLL2375DW/inf" "$pkgdir/usr/share/brother/Printers/HLL2375DW/lpd/"
+}
+