summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2016-08-20 22:15:37 -0400
committerSean Anderson2016-09-09 17:28:55 -0400
commit68284715fa24bdd21eab25e7c411b9cf87fdadcd (patch)
tree3b2f9c8a727024a26f2ffc1d0fb4bc74f930b345
downloadaur-68284715fa24bdd21eab25e7c411b9cf87fdadcd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--brother-hll2380dw.patch28
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bffce72e467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = brother-hll2380dw
+ pkgdesc = Brother LPR and CUPS driver for HL-L2380DW
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = cups
+ depends = lib32-glibc
+ source = brother-hll2380dw.patch
+ source = http://download.brother.com/welcome/dlf101770/hll2380dwcupswrapper-3.2.0-1.i386.rpm
+ source = http://download.brother.com/welcome/dlf101769/hll2380dwlpr-3.2.0-1.i386.rpm
+ md5sums = ecd2aa8403e50a739f20c76fc9032495
+ md5sums = 3fe2c6b93ec0acc7886beaa314212fca
+ md5sums = 1cf4aa246d05da5e8d3bc280d000695e
+
+pkgname = brother-hll2380dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff5da2f33ddb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sean Anderson <seanga2@gmail.com>
+pkgname="brother-hll2380dw"
+pkgver="3.2.0_1"
+pkgrel="1"
+pkgdesc="Brother LPR and CUPS driver for HL-L2380DW"
+url="http://www.brother.com"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+
+source=(brother-hll2380dw.patch
+ http://download.brother.com/welcome/dlf101770/hll2380dwcupswrapper-${pkgver//_/-}.i386.rpm
+ http://download.brother.com/welcome/dlf101769/hll2380dwlpr-${pkgver//_/-}.i386.rpm)
+md5sums=('ecd2aa8403e50a739f20c76fc9032495'
+ '3fe2c6b93ec0acc7886beaa314212fca'
+ '1cf4aa246d05da5e8d3bc280d000695e')
+prepare() {
+ patch -p1 < "$srcdir/brother-hll2380dw.patch"
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ install -d "$pkgdir/usr/share/cups/model/"
+
+ cp -R "$srcdir/opt/brother" "$pkgdir/usr/share/brother"
+
+ ln -s "/usr/share/brother/Printers/HLL2360D/cupswrapper/brother_lpdwrapper_HLL2360D" "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/HLL2360D/cupswrapper/brother-HLL2360D-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
+}
+
diff --git a/brother-hll2380dw.patch b/brother-hll2380dw.patch
new file mode 100644
index 000000000000..24ccbd0c00cc
--- /dev/null
+++ b/brother-hll2380dw.patch
@@ -0,0 +1,28 @@
+diff -aur pkg.pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW pkg.new/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW
+--- pkg.pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW 2016-08-20 21:56:06.302059556 -0400
++++ pkg.new/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW 2016-08-20 21:59:18.332061342 -0400
+@@ -43,15 +43,7 @@
+ $width=-1;
+ $height=-1;
+
+-#my $basedir = Cwd::realpath ($0);
+-my $basedir = `readlink $0`;
+-if ( $basedir eq '' ){
+- $basedir = `realpath $0`;
+-}
+-chomp($basedir);
+-
+-$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
+-
++my $basedir = "/usr/share/brother/printers/HLL2380DW"
+
+ %units = ( pt => \&pt2dot,
+ mm => \&mm2dot,
+@@ -85,6 +77,7 @@
+
+
+ $PRINTER =~ s/^\/opt\/.*\/Printers\///g;
++$PRINTER =~ s/^\/usr\/share\/.*\/Printers\///g;
+ $PRINTER =~ s/\/cupswrapper//g;
+ $PRINTER =~ s/\///g;
+