summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2024-03-26 00:34:41 +0100
committerPieter Goetschalckx2024-03-26 00:34:41 +0100
commitcd340b3aa0f302b567d03caf87679cff8ea34536 (patch)
treee7a960bfcc16a45e79a5823c12131ca98c08debd
downloadaur-cd340b3aa0f302b567d03caf87679cff8ea34536.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bab8ede3f892
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = brother-hll3240cdw-bin
+ pkgdesc = LPR driver for Brother HL-L3240CDW printer
+ pkgver = 3.5.1
+ pkgrel = 1
+ url = https://support.brother.com/g/b/producttop.aspx?c=gb&lang=en&prod=hll3240cdw_us_eu_as
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = cups
+ depends = perl
+ source = https://download.brother.com/welcome/dlf105734/hll3240cdwpdrv-3.5.1-1.i386.deb
+ b2sums = 5203cf2dddba65e152842aa4ddf13602d1c303da5f07e97071f059e7c9bae481600ebb7697643d6d77b1bb815f85b07f62b5da4a6aff5f7587a8c137c0da1951
+
+pkgname = brother-hll3240cdw-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e47ab1a4bb4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=brother-hll3240cdw-bin
+pkgver=3.5.1
+pkgrel=1
+pkgdesc="LPR driver for Brother HL-L3240CDW printer"
+arch=("i686" "x86_64")
+url="https://support.brother.com/g/b/producttop.aspx?c=gb&lang=en&prod=hll3240cdw_us_eu_as"
+license=("GPL2")
+depends=("cups" "perl")
+source=("https://download.brother.com/welcome/dlf105734/hll3240cdwpdrv-$pkgver-1.i386.deb")
+b2sums=('5203cf2dddba65e152842aa4ddf13602d1c303da5f07e97071f059e7c9bae481600ebb7697643d6d77b1bb815f85b07f62b5da4a6aff5f7587a8c137c0da1951')
+
+prepare() {
+ tar -xf data.tar.gz -C "$srcdir"
+}
+
+package() {
+ cp -R "$srcdir/opt" "$pkgdir/opt"
+
+ # symlink for lpdwrapper
+ install -d "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/opt/brother/Printers/hll3240cdw/cupswrapper/brother_lpdwrapper_hll3240cdw" "$pkgdir/usr/lib/cups/filter/"
+
+ # symlink for the PPD
+ install -d "$pkgdir/opt/cups/model/"
+ ln -s "/opt/brother/Printers/hll3240cdw/cupswrapper/brother_hll3240cdw_printer_en.ppd" "$pkgdir/opt/cups/model/"
+
+ # architecture-specific symlinks
+ ln -s "/opt/brother/Printers/hll3240cdw/lpd/$CARCH/brhll3240cdwfilter" "$pkgdir/opt/brother/Printers/hll3240cdw/lpd/"
+ ln -s "/opt/brother/Printers/hll3240cdw/lpd/$CARCH/brprintconf_hll3240cdw" "$pkgdir/opt/brother/Printers/hll3240cdw/lpd/"
+}