summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Zhao2015-08-08 23:31:31 +0200
committerMax Zhao2015-08-08 23:31:31 +0200
commit0260b5dee43d7dffe795032b647a98073e1026d1 (patch)
tree5f2d3b64d61175be44e8c117b5ed6dd3e4eef65f
downloadaur-0260b5dee43d7dffe795032b647a98073e1026d1.tar.gz
add to aur4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac191f648866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = brother-lpr-drivers-ac
+ pkgdesc = This package provides all LPR drivers for models HL-4040CN HL-4040CDN HL-4050CDN HL-4070CDW MFC-9440CN MFC-9450CDN MFC-9840CDW DCP-9040CN DCP-9042CN DCP-9045CDN
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom:brother commercial license
+ source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-ac/brother-lpr-drivers-ac_1.0.3-1-0ubuntu1_.deb
+
+pkgname = brother-lpr-drivers-ac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc2118f2f067
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: cdfk <cdfk1981-at-gmail.com>
+# Contributor: alcasa.mz <alcasa.mz-at-gmail.com>
+
+pkgname=brother-lpr-drivers-ac
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="This package provides all LPR drivers for models HL-4040CN HL-4040CDN HL-4050CDN HL-4070CDW MFC-9440CN MFC-9450CDN MFC-9840CDW DCP-9040CN DCP-9042CN DCP-9045CDN"
+license=('GPL' 'custom:brother commercial license')
+url="http://solutions.brother.com/linux/en_us/index.html"
+arch=('i686' 'x86_64')
+[ $CARCH == "x86_64" ] && _a="amd64" && md5sums=(
+ 'dcf91f4625af3abc7871859e2818fa65') && depends=('brother-lpr-drivers-common' 'a2ps' 'lib32-glibc')
+[ $CARCH == "i686" ] && _a="i386" && md5sums=(
+ '814b9c79c125771b50fc4a43dd0c5d86') && depends=('brother-lpr-drivers-common' 'a2ps')
+source=(http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver}-1-0ubuntu1_${_a}.deb)
+
+build() {
+ cd $srcdir || return 1
+ ar -x ${pkgname}_${pkgver}-1-0ubuntu1_${_a}.deb || return 1
+}
+
+package() {
+ cd $pkgdir || return 1
+ tar -xzf ${srcdir}/data.tar.gz || return 1
+}