summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Zhao2015-08-08 23:30:25 +0200
committerMax Zhao2015-08-08 23:30:25 +0200
commit42132bb8ea6a68171f34615ffd5f75ebb9e608fe (patch)
tree259c0db8dd11daa702685b7c4db2d2bceceeb695
downloadaur-42132bb8ea6a68171f34615ffd5f75ebb9e608fe.tar.gz
add to aur4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bed905ff13e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = brother-lpr-drivers-common
+ pkgdesc = This package provides common files for Brother LPR drivers packages.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom:brother commercial license
+ source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-common/brother-lpr-drivers-common_1.0.0-4-0ubuntu1_.deb
+
+pkgname = brother-lpr-drivers-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95778ff3b799
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: cdfk <cdfk1981-at-gmail.com>
+
+pkgname=brother-lpr-drivers-common
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="This package provides common files for Brother LPR drivers packages."
+license=('GPL' 'custom:brother commercial license')
+url="http://solutions.brother.com/linux/en_us/index.html"
+arch=('i686' 'x86_64')
+[ $CARCH == "x86_64" ] && _a="amd64" && md5sums=(
+ '6dc720f964d2be0a9e117289bec56a30')
+[ $CARCH == "i686" ] && _a="i386" && md5sums=(
+ '42bb28bcdd3ec22ff50fa63db87cefb6')
+source=(http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver}-4-0ubuntu1_${_a}.deb)
+
+build() {
+ cd $srcdir || return 1
+ ar -x ${pkgname}_${pkgver}-4-0ubuntu1_${_a}.deb || return 1
+}
+
+package() {
+ cd $pkgdir || return 1
+ tar -xzf ${srcdir}/data.tar.gz || return 1
+}