summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-08-14 20:38:57 +1000
committerRhinoceros2015-08-14 20:38:57 +1000
commit711c0e0ae0f652909849ea3700baecc6ac5c0090 (patch)
treecb62f1716623fd1b8f1b7bd2383fb0782f47f958
downloadaur-711c0e0ae0f652909849ea3700baecc6ac5c0090.tar.gz
Initial commit of 2.0.1-1
* Originally submitted by cdfk <cdfk1981-at-gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4219256fb46a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = brother-lpr-drivers-laser
+ pkgdesc = Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom:brother commercial license
+ source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu3_.deb
+
+pkgname = brother-lpr-drivers-laser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..478bb955892a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: cdfk <cdfk1981-at-gmail.com>
+
+pkgname=brother-lpr-drivers-laser
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW"
+license=('GPL' 'custom:brother commercial license')
+url="http://solutions.brother.com/linux/en_us/index.html"
+arch=('i686' 'x86_64')
+[ $CARCH == "x86_64" ] && _a="amd64" && md5sums=(
+ '39ad6a5c7966a2ba9a9f7f2de32f4c7e') && depends=('brother-lpr-drivers-common' 'a2ps' 'lib32-glibc')
+[ $CARCH == "i686" ] && _a="i386" && md5sums=(
+ 'ae119016dadf28962a0dacd31cf15cad') && depends=('brother-lpr-drivers-common' 'a2ps')
+source=(http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver}-3-0ubuntu3_${_a}.deb)
+
+build() {
+ cd $srcdir || return 1
+ ar -x ${pkgname}_${pkgver}-3-0ubuntu3_${_a}.deb || return 1
+}
+
+package() {
+ cd $pkgdir || return 1
+ tar -xzf ${srcdir}/data.tar.gz || return 1
+}