summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-08-14 20:48:17 +1000
committerRhinoceros2015-08-14 20:48:17 +1000
commit892e8b2a5c8983193182bc1eb3410f3898ec539f (patch)
tree30f079cd87a61368e9d0a9b7d6ea8f6264f800c5
parent711c0e0ae0f652909849ea3700baecc6ac5c0090 (diff)
downloadaur-892e8b2a5c8983193182bc1eb3410f3898ec539f.tar.gz
Upgrade to 2.0.1_3_0ubuntu5
* Bump source from ubuntu3 to ubuntu5, and change version format * Remove extraneous code checks * Upgrade to sha256sums * Minor code and style edits
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4219256fb46a..47657ff3cbe6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = brother-lpr-drivers-laser
pkgdesc = Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW
- pkgver = 2.0.1
+ pkgver = 2.0.1_3_0ubuntu5
pkgrel = 1
url = http://solutions.brother.com/linux/en_us/index.html
arch = i686
arch = x86_64
license = GPL
license = custom:brother commercial license
- source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu3_.deb
+ depends = brother-lpr-drivers-common
+ depends = a2ps
+ depends = lib32-glibc
+ source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu5__amd64.deb
+ source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu5__i386.deb
pkgname = brother-lpr-drivers-laser
diff --git a/PKGBUILD b/PKGBUILD
index 478bb955892a..3d27b64a2cf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
# Contributor: cdfk <cdfk1981-at-gmail.com>
pkgname=brother-lpr-drivers-laser
-pkgver=2.0.1
+pkgver=2.0.1_3_0ubuntu5
pkgrel=1
-pkgdesc="Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW"
+pkgdesc='Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW'
license=('GPL' 'custom:brother commercial license')
-url="http://solutions.brother.com/linux/en_us/index.html"
+url='http://solutions.brother.com/linux/en_us/index.html'
arch=('i686' 'x86_64')
-[ $CARCH == "x86_64" ] && _a="amd64" && md5sums=(
- '39ad6a5c7966a2ba9a9f7f2de32f4c7e') && depends=('brother-lpr-drivers-common' 'a2ps' 'lib32-glibc')
-[ $CARCH == "i686" ] && _a="i386" && md5sums=(
- 'ae119016dadf28962a0dacd31cf15cad') && depends=('brother-lpr-drivers-common' 'a2ps')
-source=(http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver}-3-0ubuntu3_${_a}.deb)
+[ $CARCH == 'x86_64' ] && _a='amd64' && sha256sums=(
+ 'bd35371d79dd9ea02e8563be7b429f43acf9fc8d7bf01a187d8413eb16cfa221') && depends=('brother-lpr-drivers-common' 'a2ps' 'lib32-glibc')
+[ $CARCH == 'i686' ] && _a='i386' && sha256sums=(
+ 'fba405edd53dedffed9beb604d9f301f0b241630badaa9f340387866563d2713') && depends=('brother-lpr-drivers-common' 'a2ps')
+source=("http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver//_/-}_${_a}.deb")
build() {
- cd $srcdir || return 1
- ar -x ${pkgname}_${pkgver}-3-0ubuntu3_${_a}.deb || return 1
+ ar -x "${pkgname}_${pkgver//_/-}_${_a}.deb"
}
package() {
- cd $pkgdir || return 1
- tar -xzf ${srcdir}/data.tar.gz || return 1
+ cd $pkgdir
+ tar -xzf ${srcdir}/data.tar.gz
}