summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-04-05 20:32:19 -0400
committerChris Severance2018-04-05 20:32:19 -0400
commit9b280558a50f370d11151f4f444ab1212d4dafdb (patch)
tree9d13fb8e7c455bbdb4425c5478dc3e64184f8d14
parent892e8b2a5c8983193182bc1eb3410f3898ec539f (diff)
downloadaur-9b280558a50f370d11151f4f444ab1212d4dafdb.tar.gz
Modernize PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47657ff3cbe6..be9c322e6e72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,7 @@
+# Generated by mksrcinfo v8
+# Fri Apr 6 00:31:09 UTC 2018
pkgbase = brother-lpr-drivers-laser
- pkgdesc = Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW
+ pkgdesc = LPR drivers for DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW
pkgver = 2.0.1_3_0ubuntu5
pkgrel = 1
url = http://solutions.brother.com/linux/en_us/index.html
@@ -9,9 +11,13 @@ pkgbase = brother-lpr-drivers-laser
license = custom:brother commercial license
depends = brother-lpr-drivers-common
depends = a2ps
- depends = lib32-glibc
- source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu5__amd64.deb
- source = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu5__i386.deb
+ source_i686 = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu5_i386.deb
+ md5sums_i686 = cf0120479d74d3be6796ae4d804e7b0d
+ sha256sums_i686 = fba405edd53dedffed9beb604d9f301f0b241630badaa9f340387866563d2713
+ source_x86_64 = http://mirrors.kernel.org/ubuntu/pool/multiverse/b/brother-lpr-drivers-laser/brother-lpr-drivers-laser_2.0.1-3-0ubuntu5_amd64.deb
+ depends_x86_64 = lib32-glibc
+ md5sums_x86_64 = ac86b51f47a344a1961ff13ff3cfe775
+ sha256sums_x86_64 = bd35371d79dd9ea02e8563be7b429f43acf9fc8d7bf01a187d8413eb16cfa221
pkgname = brother-lpr-drivers-laser
diff --git a/PKGBUILD b/PKGBUILD
index 3d27b64a2cf2..419335b8e812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
-# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
# Contributor: cdfk <cdfk1981-at-gmail.com>
-pkgname=brother-lpr-drivers-laser
-pkgver=2.0.1_3_0ubuntu5
-pkgrel=1
-pkgdesc='Provides all LPR drivers for models DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW'
-license=('GPL' 'custom:brother commercial license')
-url='http://solutions.brother.com/linux/en_us/index.html'
+set -u
+pkgname='brother-lpr-drivers-laser'
+pkgver='2.0.1_3_0ubuntu5'
+pkgrel='1'
+pkgdesc='LPR drivers for DCP-7010 DCP-7020 DCP-7025 DCP-8060 DCP-8065DN FAX-2820 FAX-2920 HL-2030 HL-2040 HL-2070N HL-5240 HL-5250DN HL-5270DN HL-5280DW MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-8460N MFC-8660DN MFC-8860DN MFC-8870DW'
arch=('i686' 'x86_64')
-[ $CARCH == 'x86_64' ] && _a='amd64' && sha256sums=(
- 'bd35371d79dd9ea02e8563be7b429f43acf9fc8d7bf01a187d8413eb16cfa221') && depends=('brother-lpr-drivers-common' 'a2ps' 'lib32-glibc')
-[ $CARCH == 'i686' ] && _a='i386' && sha256sums=(
- 'fba405edd53dedffed9beb604d9f301f0b241630badaa9f340387866563d2713') && depends=('brother-lpr-drivers-common' 'a2ps')
-source=("http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver//_/-}_${_a}.deb")
-
-build() {
- ar -x "${pkgname}_${pkgver//_/-}_${_a}.deb"
-}
+url='http://solutions.brother.com/linux/en_us/index.html'
+license=('GPL' 'custom:brother commercial license')
+depends=('brother-lpr-drivers-common' 'a2ps')
+depends_x86_64=('lib32-glibc')
+source_i686=("http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver//_/-}_i386.deb")
+source_x86_64=("http://mirrors.kernel.org/ubuntu/pool/multiverse/b/${pkgname}/${pkgname}_${pkgver//_/-}_amd64.deb")
+md5sums_i686=('cf0120479d74d3be6796ae4d804e7b0d')
+md5sums_x86_64=('ac86b51f47a344a1961ff13ff3cfe775')
+sha256sums_i686=('fba405edd53dedffed9beb604d9f301f0b241630badaa9f340387866563d2713')
+sha256sums_x86_64=('bd35371d79dd9ea02e8563be7b429f43acf9fc8d7bf01a187d8413eb16cfa221')
package() {
- cd $pkgdir
- tar -xzf ${srcdir}/data.tar.gz
+ set -u
+ cd "${pkgdir}"
+ bsdtar -xf "${srcdir}/data.tar".?z
+ set +u
}
+set +u