summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2022-04-22 20:56:18 +0200
committerPeter Mattern2022-04-22 20:56:18 +0200
commite8fbbd94c879904079ca8328d1bd57cc6b9d6c6f (patch)
treeb687a8f41cdd0670e7d28549fdbeede7948bcdfc
parent84e14a0238a5bc706e12b2f369072e83e35a7f49 (diff)
downloadaur-e8fbbd94c879904079ca8328d1bd57cc6b9d6c6f.tar.gz
Run chmod in PKGBUILD instead of scriptlet
Only chown needs to be run by the scriptlet to avoid issues with numerical user IDs. So run chmod in PKGBUILD to avoid error messages during transactions.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--brother-mfc-210c.install10
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0247d532dee8..204a7e53d5b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brother-mfc-210c
pkgdesc = LPR driver and CUPS wrapper for Brother MFC-210C. Covers MFC-215C as well.
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://support.brother.com
install = brother-mfc-210c.install
arch = i686
@@ -9,6 +9,7 @@ pkgbase = brother-mfc-210c
license = custom:Brother
license = GPL
makedepends = tcsh
+ depends = lib32-glibc
optdepends = cups: use CUPS printing system
optdepends = tcsh: needed to use CUPS wrapper
optdepends = lprng: use LPRng
@@ -26,4 +27,3 @@ pkgbase = brother-mfc-210c
sha256sums = d40d9ad28b0f4600fd9cfeb3ee966c92c613acd57651b100d067be93219e3638
pkgname = brother-mfc-210c
-
diff --git a/PKGBUILD b/PKGBUILD
index 13f2dceb7954..51e355b43bd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=brother-mfc-210c
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="LPR driver and CUPS wrapper for Brother MFC-210C. Covers MFC-215C as well."
arch=("i686" "x86_64")
url="http://support.brother.com"
@@ -50,6 +50,9 @@ prepare() {
./usr/share/brother/cupswrapper/cupswrapperMFC210C-1.0.0
# revert path changes to get well-behaved FHS citizens again
sed -i "s:$srcdir/usr:/usr:g" $(grep -rl "$srcdir/usr" .)
+ # adjust some permission bits
+ chmod 775 usr/share/brother/inf
+ chmod 600 usr/share/brother/inf/brMFC210Crc
}
package() {
diff --git a/brother-mfc-210c.install b/brother-mfc-210c.install
index ef47431ba093..0d17e56a2605 100644
--- a/brother-mfc-210c.install
+++ b/brother-mfc-210c.install
@@ -1,20 +1,18 @@
post_install() {
- chown root.lp /usr/share/brother/inf
- chmod 775 /usr/share/brother/inf
- chown daemon.lp /usr/share/brother/inf/brMFC210Crc
- chmod 600 /usr/share/brother/inf/brMFC210Crc
+ chown root:lp /usr/share/brother/inf
+ chown daemon:lp /usr/share/brother/inf/brMFC210Crc
echo ""
echo "LPRng:"
echo "In order to use this driver with LPRng run"
echo " /usr/share/brother/inf/setupPrintcapij MFC210C -i USB"
- echo "as root and restart the lpd daemon. (Assums the basic"
+ echo "as root and restart the lpd daemon. (Assumes the basic"
echo "configuration has been done already and lpd is up and running.)"
echo ""
echo "CUPS:"
echo "Installation of this package does not cover adding a printer"
- echo "to allow for chosing an arbitrary queue name."
+ echo "to allow for choosing an arbitrary queue name."
echo "This has to be done manually e. g. from the Web-UI."
echo ""
}