summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsdw1133222018-04-15 00:50:05 +0800
committersdw1133222018-04-15 00:50:05 +0800
commit43c072bc164265065ed196ce286a24443c21cc7a (patch)
treec9e4df7a0b7ef6f8776d6a7fdc8daf5721a269b9
downloadaur-43c072bc164265065ed196ce286a24443c21cc7a.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
-rw-r--r--brother-mfc-255cw.install9
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01ddfed7c418
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-mfc-255cw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-255CW
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-mfc-255cw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother commercial license
+ depends = cups
+ depends = perl
+ depends = bash
+ depends = lib32-glibc
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfc255cwlpr-1.1.3-1.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfc255cwcupswrapper-1.1.3-1.i386.rpm
+ md5sums = e36d4a5cebc93b95e2699e82737b25b3
+ md5sums = 5e6196f096a8bf915efbcb183e53c117
+
+pkgname = brother-mfc-255cw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a2607bc0bbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: sdw113322 <sdw113322@gmail.com>
+# Modified AUR [brother-mfc-255cw] package by sdw113322 <sdw113322@gmail.com>
+# Original AUR [brother-mfc-j220] package by Franz Rogar <franzrogar@gmail.com>
+# Original AUR [brother-hll2300d] package maintained by auruser <>
+# Original AUR [brother-hll2300d] package maintained by Mykola Bespaliuk (kolkabes [at] gmail [dot] com)
+pkgname="brother-mfc-255cw"
+_model="255cw"
+pkgver="1.1.3"
+pkgrel=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-255CW"
+url="http://solutions.brother.com/linux/en_us/"
+license=('custom:brother commercial license')
+
+arch=('i686' 'x86_64')
+
+depends=('cups' 'perl' 'bash')
+if test "$CARCH" == x86_64; then
+ depends+=('lib32-glibc')
+fi
+
+install="$pkgname.install"
+
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfc255cwlpr-$pkgver-$pkgrel.i386.rpm"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfc255cwcupswrapper-$pkgver-$pkgrel.i386.rpm"
+)
+md5sums=('e36d4a5cebc93b95e2699e82737b25b3'
+ '5e6196f096a8bf915efbcb183e53c117'
+)
+
+prepare() {
+echo "unpacking"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m 0755 -o root -g root "${srcdir}/usr/bin/brprintconf_mfc255cw" "${pkgdir}/usr/bin/brprintconf_mfc255cw"
+
+ mkdir -p "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+
+ mkdir -p "${pkgdir}/usr/lib/cups/filter"
+ echo "#! /opt/brother/Printers/mfc255cw/lpd/filtermfc255cw" > "${srcdir}/filter-shim"
+ install -m 0755 -o root -g root "${srcdir}/filter-shim" "${pkgdir}/usr/lib/cups/filter/brlpdwrappermfc255cw"
+
+ mkdir -p "${pkgdir}/usr/share/ppd/cupsfilters"
+ install -m 0644 -o root -g root "${srcdir}/opt/brother/Printers/mfc255cw/cupswrapper/brother_mfc255cw_printer_en.ppd" "${pkgdir}/usr/share/ppd/cupsfilters"
+}
diff --git a/brother-mfc-255cw.install b/brother-mfc-255cw.install
new file mode 100644
index 000000000000..3ddb04120f84
--- /dev/null
+++ b/brother-mfc-255cw.install
@@ -0,0 +1,9 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+echo "Restart CUPS to load the new files"
+echo "You can now register your new printer using the web interface at:"
+echo " http://localhost:631/"
+}