summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Harvey2017-09-19 14:08:24 -0700
committerAdam Harvey2017-09-19 14:08:24 -0700
commit619c54db020c67cf390f5c082c7c7eb8a00b9f5d (patch)
tree665c8dac4f8ef95b9e90232ed8d65b5a83f9d1f3
downloadaur-619c54db020c67cf390f5c082c7c7eb8a00b9f5d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--brother-mfc-9130cw.install12
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64a6e2d224b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-mfc-9130cw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-9130CW
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-9130cw.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfc9130cwlpr-1.1.2-1.i386.deb
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfc9130cwcupswrapper-1.1.2-1.i386.deb
+ sha256sums = 6ea12c777fd19735767757e977591d8c51353ccda7b8e4af130cc48aee85736d
+ sha256sums = 693211aff498e6cd308279899d439fa44657be0e6f5879f4ebc5530637d477ca
+
+pkgname = brother-mfc-9130cw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..754a981ca6d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Adam Harvey <adam@adamharvey.name>
+# Based on the PKGBUILD for brother-mfc-9320cw by Samuel Bernard <samuel.bernard@gmail.com>
+model="9130cw"
+pkgname="brother-mfc-$model"
+pkgver="1.1.2"
+pkgrel=1
+_revision=1
+_revision_cups=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-9130CW"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license=('GPL2')
+install="brother-mfc-${model}.install"
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${model}lpr-${pkgver}-${_revision}.i386.deb"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfc${model}cupswrapper-${pkgver}-${_revision_cups}.i386.deb")
+sha256sums=('6ea12c777fd19735767757e977591d8c51353ccda7b8e4af130cc48aee85736d'
+ '693211aff498e6cd308279899d439fa44657be0e6f5879f4ebc5530637d477ca')
+
+package() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+ cd $srcdir || return 1
+ [ -d "mfc${model}" ] || (mkdir mfc${model} || return 1)
+ for i in *.tar.gz;do tar xfz $i -C mfc${model};done || return 1
+ cd mfc${model} || return 1
+ cd opt/brother/Printers/mfc${model} || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${model} || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${model}/opt/brother/Printers/mfc${model}/inf/setupPrintcapij || return 1
+ cp -rf $srcdir/mfc${model}/usr/ $pkgdir/ || return 1
+ cp -rf $srcdir/mfc${model}/opt/ $pkgdir/ || return 1
+}
diff --git a/brother-mfc-9130cw.install b/brother-mfc-9130cw.install
new file mode 100644
index 000000000000..8eb2f98a9bc6
--- /dev/null
+++ b/brother-mfc-9130cw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfc9130cw/cupswrapper/cupswrappermfc9130cw >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}