summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Hahler2018-02-19 12:51:21 +0100
committerDaniel Hahler2018-02-19 12:51:32 +0100
commit7e44f39ee2de95f7af432ecc75ff0ec974f533e3 (patch)
tree91a722eb60cef0dd6847ea7251338168bf516f0c
parent7bf6b3630dd3df3a54e8824af2df6e5e1c0808b6 (diff)
downloadaur-brother-mfc-9142cdn.tar.gz
Revert bc5c9be: keep using deb2targz for now
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c90ab64ba326..6c960d413ab4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = brother-mfc-9142cdn
pkgdesc = LPR and CUPS driver for the Brother MFC-9142CDN
pkgver = 1.1.3
- pkgrel = 2
+ pkgrel = 3
url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
install = brother-mfc-9142cdn.install
arch = i686
arch = x86_64
license = custom:brother commercial license
+ makedepends = deb2targz
makedepends = perl
depends = lib32-libcups
source = http://download.brother.com/welcome/dlf101616/mfc9142cdnlpr-1.1.3-0.i386.deb
diff --git a/PKGBUILD b/PKGBUILD
index 331e6a5e629f..f65f2a8bf2cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
model="9142cdn"
pkgname="brother-mfc-$model"
pkgver=1.1.3
-pkgrel=2
+pkgrel=3
_revision=0
pkgdesc="LPR and CUPS driver for the Brother MFC-9142CDN"
url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
@@ -11,13 +11,15 @@ install="brother-mfc-${model}.install"
if [ "$CARCH" == 'x86_64' ]; then
depends=('lib32-libcups')
fi
-makedepends=('perl')
+makedepends=('deb2targz' 'perl')
source=("http://download.brother.com/welcome/dlf101616/mfc${model}lpr-${pkgver}-${_revision}.i386.deb"
"http://download.brother.com/welcome/dlf101617/mfc${model}cupswrapper-1.1.4-0.i386.deb")
sha256sums=('1ca1143c074c33ecfe0cdc26eb5c5e6cd9b0bbe94c116fc9c03d54de7a3029df'
'4472d0aef4148eace6d8df873b03eb1a91922791e451e90d7addde4e37c876e2')
package() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
cd $srcdir || return 1
[ -d "mfc${model}" ] || (mkdir mfc${model} || return 1)
for i in *.tar.gz;do tar xfz $i -C mfc${model};done || return 1