summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Singer2017-03-02 13:52:21 +0100
committerFelix Singer2017-03-02 13:52:21 +0100
commit76d659249e4ef249cb9ba26823d10f397bca7df5 (patch)
tree14cfe4b725a274c757ad44c4be8ad0eeac150b93
downloadaur-76d659249e4ef249cb9ba26823d10f397bca7df5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--brother-mfc-9332cdw.install12
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11b9f7ddb847
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-mfc-9332cdw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-9332CDW
+ pkgver = 20170302
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-9332cdw.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = tcsh
+ depends = perl
+ depends = a2ps
+ depends = lib32-libcups
+ source = http://download.brother.com/welcome/dlf101620/mfc9332cdwlpr-1.1.3-0.i386.deb
+ source = http://download.brother.com/welcome/dlf101621/mfc9332cdwcupswrapper-1.1.4-0.i386.deb
+ sha512sums = 78c84b107333457afaa3b12b8e3c89067c68150ca6d0d6e5df6414c56e55faca99038bf8b6937213ce925aade2d3142b738efea784893ff0e1ab1d1d7d9c1021
+ sha512sums = d0a5eb28962613649831f2d5f54a61196394f6a8c256826c813af073363881e8ab86b31c23a64c95c2ed1c1f4ca6b7bf3f25c6bc7d6ff4eaa7948e18369fc482
+
+pkgname = brother-mfc-9332cdw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c2efc02fbec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+model="9332cdw"
+pkgname="brother-mfc-$model"
+pkgver="20170302"
+pkgrel=1
+lprver="1.1.3-0"
+cwver="1.1.4-0"
+_revision=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-9332CDW"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+install="brother-mfc-${model}.install"
+depends=('tcsh' 'perl' 'a2ps' 'lib32-libcups')
+source=("http://download.brother.com/welcome/dlf101620/mfc${model}lpr-${lprver}.i386.deb"
+ "http://download.brother.com/welcome/dlf101621/mfc${model}cupswrapper-${cwver}.i386.deb")
+sha512sums=('78c84b107333457afaa3b12b8e3c89067c68150ca6d0d6e5df6414c56e55faca99038bf8b6937213ce925aade2d3142b738efea784893ff0e1ab1d1d7d9c1021'
+ 'd0a5eb28962613649831f2d5f54a61196394f6a8c256826c813af073363881e8ab86b31c23a64c95c2ed1c1f4ca6b7bf3f25c6bc7d6ff4eaa7948e18369fc482')
+
+package() {
+ ar x mfc${model}lpr-${lprver}.i386.deb && tar xzvf data.tar.gz
+ ar x mfc${model}cupswrapper-${cwver}.i386.deb && tar xzvf data.tar.gz
+
+ cd opt/brother/Printers/mfc${model}
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${model}
+ perl -i -pe 's#printcap\.local#printcap#g' ./inf/setupPrintcapij
+
+ cp -rf $srcdir/usr/ $pkgdir/
+ cp -rf $srcdir/opt/ $pkgdir/
+}
diff --git a/brother-mfc-9332cdw.install b/brother-mfc-9332cdw.install
new file mode 100644
index 000000000000..05e2685970a7
--- /dev/null
+++ b/brother-mfc-9332cdw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfc9332cdw/cupswrapper/cupswrappermfc9332cdw >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}