summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Pham2017-06-10 16:36:55 +1000
committerLeo Pham2017-06-10 16:36:55 +1000
commit50f44a640aee5146484b8b5db4bcb4872653a2b5 (patch)
tree446004a2569f9f4ea02b3b85a073322ebe5f4c24
parenta829dcbdf6fbe7242dba773c9410a116bb138496 (diff)
downloadaur-50f44a640aee5146484b8b5db4bcb4872653a2b5.tar.gz
Made PKGBUILD more compliant with standards
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD47
-rw-r--r--brother-mfc-9335cdw.install24
-rw-r--r--changelog.md13
5 files changed, 73 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e54a8299a02c..b00e2b34d851 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = brother-mfc-9335cdw
- pkgdesc = LPR, scanner and CUPS drivers for the Brother MFC-9335CDW
- pkgver = 1.0.0
- pkgrel = 1
+ pkgdesc = LPR and CUPS drivers for the Brother MFC-9335CDW
+ pkgver = 1.1.4
+ pkgrel = 2
url = http://support.brother.com/g/s/id/linux/en/index.html
install = brother-mfc-9335cdw.install
+ changelog = changelog.md
arch = i686
arch = x86_64
+ license = custom:brother
license = GPL
- license = unknown
- depends = perl
- depends = a2ps
+ makedepends = perl
+ makedepends = a2ps
+ makedepends = tar
+ depends = cups
depends = lib32-libcups
- depends = brscan4
+ optdepends = brscan4: scanning support [AUR]
+ optdepends = brscan-skey: scanner interface (touchscreen/buttons) support [AUR]
source = http://download.brother.com/welcome/dlf102677/mfc9335cdwlpr-1.1.3-0.i386.deb
source = http://download.brother.com/welcome/dlf102678/mfc9335cdwcupswrapper-1.1.4-0.i386.deb
md5sums = f993eb5322df2c9519a86ac0afcbb197
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6c3b817de49
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!PKGBUILD
+!*.install
+!.gitignore
+!changelog.md
+!.SRCINFO
+
diff --git a/PKGBUILD b/PKGBUILD
index 8aad7a4a3d9f..401293fb3644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
# Maintainer: Leo Pham <regretfulumbrella at gmail dot com>
pkgname=brother-mfc-9335cdw
-pkgver=1.0.0
-pkgrel=1
-pkgdesc="LPR, scanner and CUPS drivers for the Brother MFC-9335CDW"
-arch=("i686" "x86_64")
-url="http://support.brother.com/g/s/id/linux/en/index.html"
-license=("GPL" "unknown")
-depends=("perl" "a2ps" "lib32-libcups" "brscan4")
-install="brother-mfc-9335cdw.install"
-source=(
- "http://download.brother.com/welcome/dlf102677/mfc9335cdwlpr-1.1.3-0.i386.deb"
- "http://download.brother.com/welcome/dlf102678/mfc9335cdwcupswrapper-1.1.4-0.i386.deb"
-)
-md5sums=("f993eb5322df2c9519a86ac0afcbb197"
- "f3afb684911c55a131532bb8cfdbc672"
-)
+pkgver=1.1.4
+pkgrel=2
+pkgdesc='LPR and CUPS drivers for the Brother MFC-9335CDW'
+arch=('i686' 'x86_64')
+url='http://support.brother.com/g/s/id/linux/en/index.html'
+license=('custom:brother' 'GPL')
+depends=('cups')
+depends_x86_64=('lib32-libcups')
+optdepends=('brscan4: scanning support [AUR]'
+ 'brscan-skey: scanner interface (touchscreen/buttons) support [AUR]')
+makedepends=('perl' 'a2ps' 'tar')
+install='brother-mfc-9335cdw.install'
+changelog='changelog.md'
+source=('http://download.brother.com/welcome/dlf102677/mfc9335cdwlpr-1.1.3-0.i386.deb'
+ 'http://download.brother.com/welcome/dlf102678/mfc9335cdwcupswrapper-1.1.4-0.i386.deb')
+md5sums=('f993eb5322df2c9519a86ac0afcbb197'
+ 'f3afb684911c55a131532bb8cfdbc672')
package() {
- ar x mfc9335cdwlpr-1.1.3-0.i386.deb && tar xzvf data.tar.gz
- ar x mfc9335cdwcupswrapper-1.1.4-0.i386.deb && tar xzvf data.tar.gz
+ ar x mfc9335cdwlpr-1.1.3-0.i386.deb && tar xzvf data.tar.gz
+ ar x mfc9335cdwcupswrapper-1.1.4-0.i386.deb && tar xzvf data.tar.gz
- cd opt/brother/Printers/mfc9335cdw
- perl -i -pe "s#/etc/init.d#/etc/rc.d#g" ./cupswrapper/cupswrappermfc9335cdw
- perl -i -pe "s#printcap\.local#printcap#g" ./inf/setupPrintcapij
+ # Patch filenames to work on Arch
+ cd opt/brother/Printers/mfc9335cdw
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc9335cdw
+ perl -i -pe 's#printcap\.local#printcap#g' ./inf/setupPrintcapij
- cp -rf $srcdir/usr/ $pkgdir/
- cp -rf $srcdir/opt/ $pkgdir/
+ cp -rf $srcdir/usr/ $pkgdir/
+ cp -rf $srcdir/opt/ $pkgdir/
}
diff --git a/brother-mfc-9335cdw.install b/brother-mfc-9335cdw.install
index 0a3158bda106..8c841ee4326f 100644
--- a/brother-mfc-9335cdw.install
+++ b/brother-mfc-9335cdw.install
@@ -1,12 +1,22 @@
post_install() {
- post_upgrade;
+ post_upgrade;
}
post_upgrade() {
- /opt/brother/Printers/mfc9335cdw/cupswrapper/cupswrappermfc9335cdw >/dev/null
- if [ "$?" -eq 0 ]; then
- printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
- else
- printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
- fi
+ /opt/brother/Printers/mfc9335cdw/cupswrapper/cupswrappermfc9335cdw > /dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via \
+ the CUPS web interface (http://localhost:631).\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Make sure org.cups.cupsd.service is enabled \
+ and started, in order for printing to work.\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m If the scanner is connected wirelessly, make \
+ sure to configure it with brsaneconfig4, which will need to be installed.\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m If scanning is segfaulting, try setting the \
+ scan mode to '24bit Color' in your scanning application.\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m For the touchscreen/keypad on the scanner to \
+ work, brscan-skey.service will need to be enabled and started, and its corresponding \
+ package installed. Note that I, the package maintainer, have yet to get this working.\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
}
diff --git a/changelog.md b/changelog.md
new file mode 100644
index 000000000000..8a4ead60ca52
--- /dev/null
+++ b/changelog.md
@@ -0,0 +1,13 @@
+# Package brother-mfc-9335cdw
+
+## Version 1.1.4
+* Added forgotten cups dependency
+* Moved make dependencies into their appropriate variable
+* Moved 64bit dependencies to their appropriate variable
+* Made brscan4 an optional dependency instead of an actual dependency
+* Added brscan-skey optional dependency, so scanning might work
+ (starting a scan from a computer works, but using the scanner's interface
+ fails)
+* Updated install file to alert users of potential extra steps
+* Fixed version number to reflect the developer's version
+* Added changelog