summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Pham2017-05-21 15:38:36 +1000
committerLeo Pham2017-05-21 15:38:36 +1000
commita829dcbdf6fbe7242dba773c9410a116bb138496 (patch)
tree4838a678162ac091c2fc06f524879e70c124bfc9
downloadaur-a829dcbdf6fbe7242dba773c9410a116bb138496.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--brother-mfc-9335cdw.install12
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e54a8299a02c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = brother-mfc-9335cdw
+ pkgdesc = LPR, scanner and CUPS drivers for the Brother MFC-9335CDW
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://support.brother.com/g/s/id/linux/en/index.html
+ install = brother-mfc-9335cdw.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = unknown
+ depends = perl
+ depends = a2ps
+ depends = lib32-libcups
+ depends = brscan4
+ source = http://download.brother.com/welcome/dlf102677/mfc9335cdwlpr-1.1.3-0.i386.deb
+ source = http://download.brother.com/welcome/dlf102678/mfc9335cdwcupswrapper-1.1.4-0.i386.deb
+ md5sums = f993eb5322df2c9519a86ac0afcbb197
+ md5sums = f3afb684911c55a131532bb8cfdbc672
+
+pkgname = brother-mfc-9335cdw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aad7a4a3d9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Leo Pham <regretfulumbrella at gmail dot com>
+
+pkgname=brother-mfc-9335cdw
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="LPR, scanner and CUPS drivers for the Brother MFC-9335CDW"
+arch=("i686" "x86_64")
+url="http://support.brother.com/g/s/id/linux/en/index.html"
+license=("GPL" "unknown")
+depends=("perl" "a2ps" "lib32-libcups" "brscan4")
+install="brother-mfc-9335cdw.install"
+source=(
+ "http://download.brother.com/welcome/dlf102677/mfc9335cdwlpr-1.1.3-0.i386.deb"
+ "http://download.brother.com/welcome/dlf102678/mfc9335cdwcupswrapper-1.1.4-0.i386.deb"
+)
+md5sums=("f993eb5322df2c9519a86ac0afcbb197"
+ "f3afb684911c55a131532bb8cfdbc672"
+)
+
+package() {
+ ar x mfc9335cdwlpr-1.1.3-0.i386.deb && tar xzvf data.tar.gz
+ ar x mfc9335cdwcupswrapper-1.1.4-0.i386.deb && tar xzvf data.tar.gz
+
+ cd opt/brother/Printers/mfc9335cdw
+ perl -i -pe "s#/etc/init.d#/etc/rc.d#g" ./cupswrapper/cupswrappermfc9335cdw
+ perl -i -pe "s#printcap\.local#printcap#g" ./inf/setupPrintcapij
+
+ cp -rf $srcdir/usr/ $pkgdir/
+ cp -rf $srcdir/opt/ $pkgdir/
+}
+
diff --git a/brother-mfc-9335cdw.install b/brother-mfc-9335cdw.install
new file mode 100644
index 000000000000..0a3158bda106
--- /dev/null
+++ b/brother-mfc-9335cdw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfc9335cdw/cupswrapper/cupswrappermfc9335cdw >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}