summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgenofire2020-02-05 10:44:27 +0100
committergenofire2020-02-05 10:44:27 +0100
commit15c04c766704e690f7c3effd94b6d223f91978df (patch)
treef79ff00c2f1e05ff28009d64d891e41ecc669676
downloadaur-15c04c766704e690f7c3effd94b6d223f91978df.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
-rw-r--r--brother-mfc-9342cdw.install9
-rw-r--r--lpr-license.txt11
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e3f774a7326
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = brother-mfc-9342cdw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-9342CDW
+ pkgver = 1.1.3_0
+ pkgrel = 0
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-9342cdw.install
+ arch = i686
+ arch = x86_64
+ license = custom:Brother commercial license
+ license = GPL2
+ depends = cups
+ depends = ghostscript
+ depends = a2ps
+ source = https://download.brother.com/welcome/dlf101626/mfc9342cdwlpr-1.1.3-0.i386.rpm
+ source = https://download.brother.com/welcome/dlf101627/mfc9342cdwcupswrapper-1.1.4-0.i386.rpm
+ source = lpr-license.txt
+ sha256sums = 66e0896c58bb073ccae6cffbbb0ef3cd21b9fdc20145e991f10b7809c003bde0
+ sha256sums = 67d8ba9fbb22c21b093951872f81fc3697023953f6c9f9e1ab9dcdd757df5239
+ sha256sums = 9d85a8aafdaac8fac80e04234ad2acf5642bbf0b91ee582d2a89519a55f6dd67
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-mfc-9342cdw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..361443e9ba99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Submitter: voidptr <aur at voidptr dot net>
+# Contributor: Andrew Hacking <ahacking at gmail>
+# Maintainer: Tom Wasiluk <tomasz at wasil dot uk>
+# Co-maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
+
+_model='9342cdw'
+pkgname=brother-mfc-${_model}
+pkgver=1.1.3_0
+pkgrel=0
+_cupswrapper_ver='1.1.4-0'
+#https://download.brother.com/welcome/dlf101624/mfc9342cdwlpr-1.1.3-0.i386.deb
+pkgdesc='LPR and CUPS driver for the Brother MFC-9342CDW'
+url='http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html'
+arch=(i686 x86_64)
+license=('custom:Brother commercial license' GPL2)
+install=brother-mfc-${_model}.install
+depends=(cups ghostscript a2ps)
+depends_x86_64=(lib32-glibc)
+
+source=("https://download.brother.com/welcome/dlf101626/mfc${_model}lpr-${pkgver//_/-}.i386.rpm"
+ "https://download.brother.com/welcome/dlf101627/mfc${_model}cupswrapper-${_cupswrapper_ver}.i386.rpm"
+ 'lpr-license.txt')
+sha256sums=('66e0896c58bb073ccae6cffbbb0ef3cd21b9fdc20145e991f10b7809c003bde0'
+ '67d8ba9fbb22c21b093951872f81fc3697023953f6c9f9e1ab9dcdd757df5239'
+ '9d85a8aafdaac8fac80e04234ad2acf5642bbf0b91ee582d2a89519a55f6dd67')
+
+prepare() {
+ install -d usr/share/cups/model usr/lib/cups/filter
+ wrapper=opt/brother/Printers/mfc${_model}/cupswrapper/cupswrappermfc${_model}
+ sed -i '/^ *lpadmin/d;/^sleep/Q' "$wrapper"
+ perl -i -spe 's#/(usr|opt)#$srcdir/$1#g;s#/model/Brother#/model#g' -- -srcdir="$srcdir" "$wrapper"
+ ./"$wrapper"
+ rm "$wrapper"
+ perl -i -spe 's/$srcdir//' -- -srcdir="$srcdir" usr/lib/cups/filter/*lpdwrapper*
+
+ rm opt/brother/Printers/mfc${_model}/cupswrapper/brother_mfc${_model}_printer_en.ppd
+ # /etc/printcap is managed by cups
+ rm opt/brother/Printers/mfc${_model}/inf/setupPrintcap*
+}
+
+package() {
+ cp -R usr/ opt/ "${pkgdir}/"
+ install -Dm644 lpr-license.txt "${pkgdir}/usr/share/licenses/${pkgname}/lpr-license.txt"
+}
diff --git a/brother-mfc-9342cdw.install b/brother-mfc-9342cdw.install
new file mode 100644
index 000000000000..39e68edbc632
--- /dev/null
+++ b/brother-mfc-9342cdw.install
@@ -0,0 +1,9 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ echo "Restart CUPS to load the new files"
+ echo "You can now register your new printer using the web interface at:"
+ echo " http://localhost:631/"
+}
diff --git a/lpr-license.txt b/lpr-license.txt
new file mode 100644
index 000000000000..0d32eb1475ce
--- /dev/null
+++ b/lpr-license.txt
@@ -0,0 +1,11 @@
+This Agreement provides terms and conditions for license grant from Brother Industries, Ltd ("Broher"). Brother, who owns all copyrights to the software that is distributed with this Agreement ("Software") to recipients thereof ("User"), for use of the Software. User shall have the right to use the Software only in accordance with the terms and conditions of this Agreement. Any use by User of the Software shall be deemed as its agreement hereto.
+Note:
+Please click on "I Accept" while holding down "Shift" or right click on "I Accept" and select "Save Target As,,," from the menu.
+
+Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.
+
+Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.
+
+The license of the Software from Brother hereunder is granted "AS IS." BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT.
+Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage.
+Further, Brother shall have no liability to disclose and/or distribute the source cord of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother's implied agreement or undertakings to disclose and/or distribute the source cord of the Software. \ No newline at end of file